Katalog podatności CVE

Przetłumaczone opisy podatności z bazy NVD NIST - w języku polskim

Przeglądaj podatności według pakietu

Katalog CISA KEV zaktualizowany: (v2026.11.04)

Cotygodniowy digest CVE

Jeden mail w tygodniu z nowo opublikowanymi podatnościami, o których warto wiedzieć. Bez zakładania konta.

Digest dotyczy ogólnie nowych podatności, nie Twoich serwerów. Jeśli chcesz wiedzieć, które z nich faktycznie działają w Twojej infrastrukturze, tym zajmuje się Secvalis : skanuje Twoje maszyny i zgłasza wyłącznie to, co ich dotyczy.

Zgadzam się na otrzymywanie cotygodniowego digestu CVE na podany adres e-mail. Zgodę mogę wycofać w każdej chwili linkiem w stopce każdej wiadomości.

GHSA-5qhf-9phg-95m2
Niskie
—

Metoda Loofah::HTML5::Scrub.allowed_uri? niepoprawnie odrzuca URI javascript: lub vbscript:, gdy schemat jest podzielony przez numeryczne odniesienie znakowe bez średnika. Przeglądarka dekoduje takie odniesienia i rozwiązuje URL do wykonywalnego schematu javascript:, podczas gdy allowed_uri? uznaje go za bezpieczny.

CVE-2019-20916
Wysokie
—

Podatność w pakiecie pip dla języka Python przed wersją 19.2 umożliwia przemieszczanie się po katalogach (directory traversal) podczas instalacji z podanego URL. Atakujący może wykorzystać nagłówek Content-Disposition zawierający '../' w nazwie pliku, co pozwala na nadpisanie plików, np. /root/.ssh/authorized_keys.

CVE-2025-27152
Wysokie
—

Podatność w bibliotece axios pozwala na wysyłanie żądań do absolutnych URL-i zamiast względnych, co może prowadzić do ataków SSRF i wycieku poświadczeń. Nawet przy ustawionym baseURL, axios ignoruje to i wysyła żądanie do podanego absolutnego adresu URL.

CVE-2020-36604
Wysokie
—

Podatność w bibliotece hoek przed wersją 8.5.1 oraz w wersjach 9.x przed 9.0.3 umożliwia zatruwanie prototypu w funkcji clone. Atakujący może wykorzystać tę lukę do modyfikacji prototypu obiektów, co prowadzi do nieautoryzowanego dostępu lub wykonania kodu.

GHSA-cj75-f6xr-r4g7
Średnie
—

Istnieje możliwa podatność na cross-site scripting (XSS) w rails-html-sanitizer, gdy sanityzer jest skonfigurowany do zezwalania na element referencyjny SVG, taki jak <use>. Jest to powiązane z GHSA-9wjq-cp2p-hrgf w Loofah, którego logika lokalnych referencji SVG jest odwzorowana w rails-html-sanitizer.

CVE-2025-5889
Niskie
—

W bibliotece brace-expansion do wersji 1.1.11, 2.0.1, 3.0.0 i 4.0.0 wykryto podatność polegającą na nieefektywnej złożoności wyrażenia regularnego w funkcji expand w pliku index.js. Atak może być przeprowadzony zdalnie.

GHSA-8whx-365g-h9vv
Niskie
—

Metoda Loofah::HTML5::Scrub.allowed_uri? niepoprawnie odrzuca URI javascript:, gdy schemat jest podzielony lub poprzedzony nazwanymi odniesieniami znakowymi HTML5 &Tab; (tabulacja) lub &NewLine; (znak nowej linii). Jest to obejście poprawki dla GHSA-46fp-8f5p-pf2m, która dotyczyła równoważnych numerycznych odniesień znakowych.

CVE-2020-25659
Średnie
—

Podatność w bibliotece python-cryptography 3.2 umożliwia ataki timingowe Bleichenbachera na API deszyfrowania RSA. Atakujący może wykorzystać różnice czasowe w przetwarzaniu prawidłowych szyfrogramów PKCS#1 v1.5.

CVE-2022-42919
Wysokie
—

Podatność w Pythonie 3.9.x przed 3.9.16 i 3.10.x przed 3.10.9 na systemie Linux umożliwia lokalną eskalację uprawnień w niestandardowej konfiguracji. Biblioteka multiprocessing z metodą startową forkserver pozwala na deserializację pickle'ów od dowolnego użytkownika w tej samej sieci lokalnej maszyny.

GHSA-9wjq-cp2p-hrgf
Średnie
—

Sanityzer HTML5 biblioteki Loofah ograniczał tylko atrybut xlink:href na niektórych elementach SVG do lokalnych, wewnątrzdokumentowych odwołań. Przeglądarki akceptują również zwykły atrybut href jako alternatywę dla przestarzałego xlink:href zgodnie ze specyfikacją SVG 2, ale Loofah nie stosował tego samego ograniczenia do niego.

CVE-2023-27043
Średnie
—

Moduł email w Pythonie do wersji 3.11.3 błędnie parsuje adresy e-mail zawierające znaki specjalne. Nieprawidłowa część nagłówka RFC2822 jest identyfikowana jako wartość addr-spec.

CVE-2025-58767
Niskie
—

REXML to zestaw narzędzi XML dla Ruby. Wersje REXML od 3.3.3 do 3.4.1 mają podatność na atak DoS podczas parsowania XML zawierającego wiele deklaracji XML. Jeśli przetwarzasz niezaufane XML-e, możesz być narażony na tę podatność. Wersja REXML 3.4.2 lub nowsza zawiera poprawki.

CVE-2023-50387
Wysokie
—

Podatność KeyTrap w protokole DNSSEC umożliwia zdalnemu atakującemu przeprowadzenie ataku typu Denial of Service (DoS) poprzez wysłanie odpowiedzi DNSSEC zawierających wiele rekordów DNSKEY i RRSIG. Powoduje to nadmierne zużycie CPU na serwerze DNS, co może prowadzić do jego przeciążenia.

CVE-2023-50868
Wysokie
—

Podatność w protokole DNS, związana z aspektem Closest Encloser Proof w RFC 5155 (gdy pominięto wytyczne RFC 9276), umożliwia zdalnym atakującym przeprowadzenie ataku typu „odmowa usługi” (DoS) poprzez wywołanie nadmiernego zużycia CPU na obliczenia SHA-1. Atak polega na wysyłaniu odpowiedzi DNSSEC w ramach ataku na losowe subdomeny, znanego jako problem NSEC3.

CVE-2019-3844
Wysokie
—

Odkryto, że usługa systemd korzystająca z właściwości DynamicUser może uzyskać nowe uprawnienia poprzez wykonanie binarek SUID, co pozwala na tworzenie binarek należących do tymczasowej grupy usługi z ustawionym bitem setgid. Lokalny atakujący może wykorzystać tę lukę do uzyskania dostępu do zasobów, które będą.

CVE-2022-4415
Średnie
—

Podatność w systemd powoduje, że systemd-coredump nie respektuje ustawienia jądra fs.suid_dumpable, co może prowadzić do lokalnego wycieku informacji.

CVE-2020-16156
Wysokie
—

Podatność w CPAN 2.28 umożliwia obejście weryfikacji podpisów cyfrowych. Atakujący może dostarczyć nieautoryzowany kod, który zostanie uznany za prawidłowo podpisany.

CVE-2023-4641
Średnie
—

W narzędziu shadow-utils wykryto usterkę polegającą na nieprawidłowym czyszczeniu bufora przy dwukrotnym wprowadzaniu nowego hasła. Jeśli drugie wprowadzenie hasła zakończy się niepowodzeniem, pierwsze hasło pozostaje w pamięci, co może umożliwić atakującemu z odpowiednim dostępem jego odzyskanie.

CVE-2023-31484
Wysokie
—

Podatność w CPAN.pm przed wersją 2.35 powoduje, że nie weryfikuje on certyfikatów TLS podczas pobierania dystrybucji przez HTTPS. Oznacza to, że atakujący typu man-in-the-middle może podmienić pobierane pakiety na złośliwe.

CVE-2019-3843
Wysokie
—

W systemd odkryto podatność, w której usługa używająca właściwości DynamicUser może utworzyć binarny plik SUID/SGID, który będzie mógł być uruchomiony z tymczasowym UID/GID usługi nawet po jej zakończeniu. Lokalny atakujący może wykorzystać tę lukę, aby uzyskać dostęp do zasobów należących do potencjalnie innego UID/GID.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS