CVE-2026-85028
WysokieCVSS 7.8Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 2 - wyżej niż 2% wszystkich znanych CVE
Streszczenie
Tworzenie pliku tymczasowego w katalogu z niebezpiecznymi uprawnieniami w komponencie instalacyjnym narzędzia FPGA w AWS FPGA Development Kit (aws-fpga) przed wersją 2.3.4 może pozwolić lokalnym użytkownikom na wykonanie dowolnego kodu z uprawnieniami roota poprzez spreparowaną zawartość powłoki umieszczoną w przewidywalnej ścieżce w światowo zapisywalnym katalogu tymczasowym, którą krok instalacyjny odczytuje po podniesieniu swoich uprawnień. Aby zaradzić temu problemowi, użytkownicy powinni zaktualizować do wersji 2.3.4.
Ocena ryzyka
Lokalny użytkownik może uzyskać pełną kontrolę nad systemem z uprawnieniami roota, co może prowadzić do całkowitej kompromitacji hosta.
Rekomendacja
Należy zaktualizować AWS FPGA Development Kit do wersji 2.3.4 lub nowszej oraz sprawdzić uprawnienia katalogów tymczasowych.
Powiązane podatności
- CVE-2026-123614Krytyczne
W imgproxy od wersji 4.0.0 do 4.0.16 występuje przepełnienie liczb całkowitych w loaderze ICO, które pozwala zdalnym atakującym wywołać przepełnienie bufora sterty poprzez spreparowaną wartość data_size. Atakujący może przesłać spreparowany obraz ICO, w którym data_size powoduje zawinięcie alokacji w vips/icoload.c, uszkadzając pamięć sterty, co prowadzi do awarii procesu lub wykonania kodu.
- CVE-2026-123551Krytyczne
OpenAM od wersji 14.0.0 do 16.1.4 zawiera podatność na ujawnienie informacji, która pozwala nieuwierzytelnionym atakującym odczytać aktywne tokeny sesji z WebSocketu powiadomień. Atakujący mogą obejść sprawdzenie przeznaczone tylko dla agentów poprzez niezwalidowane wewnętrzne przekierowanie na starszych punktach końcowych Liberty ID-FF, zbierając tokeny iPlanetDirectoryPro w celu przejęcia sesji użytkowników i administratorów.
- CVE-2026-123550Krytyczne
OpenAM przed wersją 16.1.4 zawiera podatność na obejście uwierzytelniania w usłudze SAML v2.0 service provider, która akceptuje niepodpisane asercje w powiązaniach ECP (PAOS) i HTTP-Artifact, gdy WantAssertionsSigned ma wartość false. Nieuwierzytelnieni zdalni atakujący mogą przesłać sfałszowane asercje, aby uzyskać sesje jako dowolny zmapowany użytkownik, w tym administrator, i przejąć logowanie jednokrotne do aplikacji zależnych.
- CVE-2026-123549Krytyczne
OpenAM przed wersją 16.1.4 nie egzekwuje listy Valid Creation Attributes podczas samodzielnej rejestracji, co pozwala anonimowym atakującym ustawić zastrzeżone atrybuty, w tym członkostwo w grupach. Atakujący mogą zarejestrować się przez starszy punkt końcowy REST samoobsługi lub przepływ User Self-Service, aby dołączyć do grup administracyjnych i uzyskać pełną kontrolę administracyjną nad OpenAM.
- CVE-2026-124060Krytyczne
W urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884 wykryto podatność w funkcji UploadCustomModule w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem File prowadzi do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit jest publicznie dostępny i może być wykorzystany.
- CVE-2026-124059Krytyczne
Wykryto podatność bezpieczeństwa w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiWdsAddConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr prowadzi do przepełnienia bufora. Atak można zainicjować zdalnie, a exploit został publicznie ujawniony i może być wykorzystany.
- CVE-2026-124058Krytyczne
Zidentyfikowano słabość w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiRepeaterConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr może prowadzić do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit został udostępniony publicznie i może być wykorzystany w atakach.
- CVE-2026-124057Krytyczne
W TOTOLINK CA300-PoE 6.2c.884 odkryto lukę w zabezpieczeniach funkcji setWiFiMultipleConfig w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem Key1Str1 prowadzi do przepełnienia bufora, a atak można zainicjować zdalnie. Exploit został publicznie udostępniony i może być wykorzystany.
- CVE-2026-123966Krytyczne
W urządzeniu Tenda AC19 w wersji 16.03.10.07 wykryto podatność w funkcji saveParentControlInfo w pliku /goform/saveParentControlInfo. Manipulacja argumentem deviceId powoduje przepełnienie bufora na stercie. Atak można przeprowadzić zdalnie, a exploit został publicznie ujawniony.
- CVE-2026-120984Krytyczne
W komponencie zarządzania klientami serwera Keycloak wykryto błąd. Podczas tworzenia lub importu klienta z włączonymi usługami autoryzacji system nie czyści prawidłowo atrybutu sesji używanego podczas konfiguracji. Uwierzytelniony atakujący z uprawnieniami do zarządzania klientami może ominąć mechanizmy bezpieczeństwa i przesłać złośliwą politykę JavaScript, która jest wykonywana na serwerze.
Oryginalny opis (angielski, źródło NVD)
Creation of a temporary file in a directory with insecure permissions in the FPGA management tool installation component in AWS FPGA Development Kit (aws-fpga) before 2.3.4 might allow local users to execute arbitrary code with root privileges via crafted shell content placed at a predictable path in a world-writable temporary directory, which the installation step reads after elevating its own privileges. To remediate this issue, users should upgrade to version 2.3.4.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

