CVE-2026-82377
KrytyczneCVSS 9.9Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 43 - wyżej niż 43% wszystkich znanych CVE
Streszczenie
Apache Roller 6.1.5 zawiera podatność braku autoryzacji, która pozwala uwierzytelnionemu użytkownikowi na odczyt, modyfikację lub usunięcie treści bloga należącego do innych blogów poprzez starsze interfejsy API XML-RPC Blogger i MetaWeblog. Handlery uwierzytelniają wywołującego, ale nie weryfikują jego uprawnień do bloga lub wpisu, którego dotyczy operacja. Podatność dotyczy tylko instalacji z włączonym niestandardowym globalnym ustawieniem XML-RPC; flaga API dla poszczególnych blogów jest domyślnie włączona dla blogów utworzonych przez interfejs użytkownika.
Ocena ryzyka
Uwierzytelniony użytkownik może modyfikować lub usuwać treści innych blogów, co prowadzi do naruszenia integralności danych i potencjalnych szkód wizerunkowych. Ryzyko jest ograniczone do instalacji z włączonym globalnym ustawieniem XML-RPC.
Rekomendacja
Zaktualizuj Apache Roller do wersji 6.1.6 lub nowszej, która stosuje jawną kontrolę uprawnień dla każdej metody, albo pozostaw funkcję XML-RPC wyłączoną.
Inne podatności w Apache Roller
Zobacz wszystkie- CVE-2026-86507Średnie
Podatność w Apache Roller 6.1.5 polega na niewłaściwej neutralizacji danych wejściowych, co pozwala anonimowemu zdalnemu atakującemu przechowywać spreparowany URL autora komentarza, który może wykonać skrypt w sesji moderatora bloga lub administratora globalnego podczas przeglądania strony zarządzania komentarzami. Dotyczy to witryn, które pozwalają na komentarze na co najmniej jednym blogu i których moderator przegląda nadesłany komentarz; nie jest wymagane żadne niestandardowe ustawienie serwera.
- CVE-2026-82383Wysokie
W Apache Roller 6.1.5 brakuje uwierzytelniania dla krytycznej funkcji, co pozwala nieuwierzytelnionemu zdalnemu atakującemu trwale zmienić globalną wartość konfiguracji witryny (wybór bloga na stronie głównej). Akcja setup pozostaje anonimowo dostępna po instalacji i zapisuje konfigurację bez sprawdzenia autoryzacji.
- CVE-2026-82382Średnie
Podatność Reflected Cross-site Scripting (XSS) w Apache Roller 6.1.5 pozwala zdalnemu atakującemu na wykonanie skryptu w przeglądarce odwiedzającego bloga korzystającego z dołączonego motywu frontpage, poprzez podanie spreparowanego parametru blog-directory, który strona katalogu odzwierciedla bez odpowiedniego escapowania. Dotyczy to tylko blogów używających dołączonego motywu frontpage, a ofiara musi kliknąć spreparowany link.
- CVE-2026-82381Średnie
Podatność Stored Cross-site Scripting (XSS) w Apache Roller 6.1.5 pozwala użytkownikowi z prawami autorskimi na blogu na zapisanie spreparowanej treści, która jest później zapisywana w literałach łańcuchowych JavaScript i miejscach znaczników interfejsu autorskiego bez odpowiedniego kodowania, powodując wykonanie zapisanego skryptu w przeglądarce innego autora lub administratora. Nie wymaga żadnej opcjonalnej funkcji ani niestandardowej konfiguracji; dotyczy to blogów z wieloma autorami lub administratorami, którzy nie ufają sobie nawzajem.
- CVE-2026-82380Wysokie
W Apache Roller 6.1.5 występuje podatność Cross-Site Request Forgery (CSRF), która pozwala zdalnemu atakującemu nakłonić zalogowanego użytkownika do wykonania akcji zmieniających stan w jego imieniu. Filtry walidacji CSRF akceptują żądanie, które nie przesyła wymaganego tokenu salt, walidując zamiast tego wartość wygenerowaną przez sam serwer.
- CVE-2026-82375Wysokie
Podatność Server-Side Request Forgery (SSRF) w Apache Roller 6.1.5 pozwala uwierzytelnionemu użytkownikowi z prawem edycji wpisów na blogu na wywoływanie wychodzących żądań HTTP do celów wybranych przez atakującego poprzez mechanizmy Trackback i enclosure. Kontrolka Trackback jest ukryta w standardowym interfejsie, ale jej akcja pozostaje bezpośrednio dostępna, a domyślna pusta lista dozwolonych Trackbacków zezwala na wszystkie cele. Żądania mogą docierać do adresów loopback i sieci prywatnych.
- CVE-2015-0249Wysokie
Szablon strony weblog w Apache Roller w wersjach 5.1 do 5.1.1 pozwala zdalnym uwierzytelnionym użytkownikom z uprawnieniami administratora na wykonanie dowolnego kodu Java za pomocą spreparowanego języka Velocity Text Language (VTL).
- CVE-2026-82384Krytyczne
Apache Roller 6.1.5 zawiera podatność deserializacji niezaufanych danych, ponieważ punkt końcowy XML-RPC akceptuje typy rozszerzeń dostawcy, które są deserializowane podczas przetwarzania żądania, przed uwierzytelnieniem. Servlet jest mapowany bezwarunkowo, więc parsowanie następuje nawet gdy globalna funkcja XML-RPC jest wyłączona; nie jest wymagana żadna niestandardowa konfiguracja. Może to prowadzić do zdalnego wykonania kodu.
- CVE-2026-82378Krytyczne
Apache Roller 6.1.5 zawiera podatność nieprawidłowej autoryzacji w punkcie końcowym autoryzacji OAuth 1.0a. Nieuwierzytelniony zdalny atakujący, który pozna ważny token żądania dla skonfigurowanego konsumenta ogólnodostępnego, może powiązać ten token z dowolnym kontem użytkownika, w tym administratorem, wysyłając niepodpisane żądanie autoryzacji. Punkt końcowy ustala tożsamość autoryzującą na podstawie wartości dostarczonej w żądaniu, a nie uwierzytelnionej sesji.
- CVE-2014-0030Krytyczne
Wsparcie protokołu XML-RPC w Apache Roller przed wersją 5.0.3 umożliwia atakującym przeprowadzanie ataków XML External Entity (XXE) za pomocą nieokreślonych wektorów.
Oryginalny opis (angielski, źródło NVD)
Missing Authorization in Apache Roller 6.1.5 allows an authenticated user to read, modify, or delete weblog content belonging to other weblogs through the legacy XML-RPC Blogger and MetaWeblog APIs, because the handlers authenticate the caller but do not verify the caller's permission on the weblog or entry actually affected. Only installations that enable the non-default global XML-RPC setting are affected; the per-weblog API flag defaults to enabled for UI-created weblogs. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which applies an explicit per-method permission check, or to keep the XML-RPC feature disabled.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

