CVE-2026-77147
ŚrednieCVSS 6.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 21 - wyżej niż 21% wszystkich znanych CVE
Streszczenie
Podatność na wstrzykiwanie kodu w Apache Syncope. Administrator z odpowiednimi uprawnieniami do Implementations może utworzyć złośliwą klasę Groovy Command zawierającą niezaufany kod w statycznej implementacji CommandArgs, omijając zabezpieczenia piaskownicy Groovy. Problem dotyczy Apache Syncope w wersjach od 3.0.0-M0 do 3.0.16, od 4.0.0-M0 do 4.0.7 oraz od 4.1.0-M0 do 4.1.2. Zalecane jest uaktualnienie do wersji 4.0.8 / 4.1.3, które naprawiają ten problem.
Ocena ryzyka
Administrator z uprawnieniami może wykonać dowolny kod, co prowadzi do pełnej kompromitacji systemu Syncope i danych.
Rekomendacja
Zaktualizuj Apache Syncope do wersji 4.0.8 lub 4.1.3, które zawierają poprawkę.
Inne podatności w Apache Syncope
Zobacz wszystkie- CVE-2026-114364Nieznane
Apache Syncope zawiera niepełną poprawkę dla CVE-2026-77051 — podatność na wstrzyknięcie SQL (SQL injection) poprzez nieoczyszczone parametry opEvent. Administrator z odpowiednimi uprawnieniami może wykonać dowolny SQL za pomocą zapytań złożonych (stacked queries).
- CVE-2026-113687Nieznane
Apache Syncope ma podatność związaną z niewłaściwą izolacją (compartmentalization). Administrator z odpowiednimi uprawnieniami do Implementations może utworzyć złośliwą klasę Groovy uruchamiającą niezaufany kod w osobnym wątku, omijając piaskownicę bezpieczeństwa Groovy.
- CVE-2026-113511Nieznane
Apache Syncope ma podatność na obejście autoryzacji poprzez klucz kontrolowany przez użytkownika. Delegowany administrator może przenieść poddrzewo Realm poza granice administracyjne bez uprawnień do miejsca docelowego.
- CVE-2026-110535Nieznane
Apache Syncope ma podatność związaną z niewłaściwym zarządzaniem uprawnieniami. Samodzielna aktualizacja AuthProfile pozwala użytkownikom niebędącym administratorami skonfigurować podszywanie się (impersonation) dla uwierzytelniania zastępczego WA.
- CVE-2026-109083Nieznane
Apache Syncope ma podatność związaną z niewłaściwą izolacją. Administrator z odpowiednimi uprawnieniami może zaimportować dowolną definicję procesu BPMN przez REST API, a następnie uruchomić proces; wyrażenie JUEL w procesie jest wykonywane bezpośrednio na serwerze bez piaskownicy.
- CVE-2026-73370Krytyczne
Podatność niepoprawnej autoryzacji w Apache Syncope dotyczy usługi Reconciliation (pull i push). Ze względu na niekompletne sprawdzenia bezpieczeństwa delegowanej administracji, wywołania od administratorów bez odpowiednich uprawnień mogą zostać zaakceptowane, co pozwala na niedozwolone działania.
- CVE-2026-78330Krytyczne
Podatność nieprawidłowego przypisania uprawnień w Apache Syncope. Gdy ujawnione zostaną ustawienia JWKS dla wewnętrznego uwierzytelniania JWT (przynajmniej protokół i klucz), atakujący po pomyślnym uwierzytelnieniu i uzyskaniu ważnego JWT z niskimi uprawnieniami może uzyskać uprawnienia administratora.
- CVE-2026-77181Krytyczne
W Apache Syncope występuje luka nieprawidłowej autoryzacji. Administrator posiadający uprawnienie do aktualizacji ClientApp nie może wykonać powiązanej operacji, natomiast uprawnienie do tworzenia ClientApp jest sprawdzane zarówno dla operacji tworzenia, jak i aktualizacji.
- CVE-2026-77051Krytyczne
W Apache Syncope występuje luka SQL Injection wynikająca z niewłaściwej neutralizacji specjalnych elementów w zapytaniach SQL. Administrator z odpowiednimi uprawnieniami może wykonać dowolny kod SQL poprzez zapytania złożone, wykorzystując nieoczyszczone parametry entityKey i opEvent.
- CVE-2026-75030Krytyczne
W Apache Syncope występuje luka braku autoryzacji. Administrator posiadający uprawnienia do wykonywania zadań może masowo tworzyć lub usuwać członkostwa w grupach, niezależnie od swoich uprawnień administracyjnych związanych z grupami.
Oryginalny opis (angielski, źródło NVD)
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

