CVE-2026-76801
WysokieCVSS 8.8Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 41 - wyżej niż 41% wszystkich znanych CVE
Streszczenie
Wtyczka FireBox dla WordPressa (do wersji 3.1.10 włącznie) jest podatna na zdalne wykonanie kodu z powodu obejścia listy czarnych znaków w funkcji Executer::allowedToRun() oraz braku sanityzacji wartości reguł warunków PHP przechowywanych przez REST API firebox_meta. Uwierzytelnieni atakujący z dostępem na poziomie autora lub wyższym mogą wykonać kod na serwerze. Na stronach zaktualizowanych z wersji wcześniejszej niż 3.1.10 funkcja Migrator::preserveCampaignRoleAccess() automatycznie nadaje rolę Autorowi uprawnienia edit_fireboxes i publish_fireboxes, obniżając próg wejścia do poziomu autora.
Ocena ryzyka
Atakujący z uprawnieniami autora może wykonać dowolny kod na serwerze, co może prowadzić do przejęcia kontroli nad witryną, kradzieży danych lub dalszych ataków.
Rekomendacja
Zaleca się natychmiastową aktualizację wtyczki FireBox do najnowszej wersji, która zawiera poprawkę, oraz ograniczenie uprawnień użytkowników do minimum.
Inne podatności w FireBox
Zobacz wszystkie- CVE-2026-104724Średnie
Wtyczka FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment dla WordPressa jest podatna na ogólny SQL Injection przez warunek wyświetlania formularza FireBox we wszystkich wersjach do 3.1.13 włącznie, z powodu niewystarczającej ucieczki parametru dostarczonego przez użytkownika i braku odpowiedniego przygotowania istniejącego zapytania SQL. Umożliwia to uwierzytelnionym atakującym z dostępem na poziomie autora i wyższym dołączanie dodatkowych zapytań SQL do istniejących zapytań, które mogą być użyte do wyodrębnienia wrażliwych informacji z bazy danych. Na świeżych instalacjach w wersji 3.1.10 i nowszych wykorzystanie wymaga dostępu na poziomie administratora; jednak na stronach zaktualizowanych z wersji wcześniejszej niż 3.1.10, migracja preserveCampaignRoleAccess() nadaje uprawnienie edit_fireboxes każdej roli, która wcześniej miała edit_posts, zmniejszając minimalny wymagany przywilej do poziomu autora.
- CVE-2025-67545Średnie
Wtyczka FireBox jest podatna na atak typu Stored Cross-site Scripting (XSS) z powodu niewłaściwej neutralizacji danych wejściowych podczas generowania stron internetowych. Podatność dotyczy wersji od n/a do <= 3.1.0-free.
Oryginalny opis (angielski, źródło NVD)
The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

