CVE-2026-72718
WysokieCVSS 7.0Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 12 - wyżej niż 12% wszystkich znanych CVE
Streszczenie
goose przed wersją 1.44.0 ma podatność, w której polecenie `goose review` uruchamia `git` bez oczyszczania konfiguracji, co pozwala złośliwemu repozytorium na wykonanie dowolnych poleceń na hoście.
Ocena ryzyka
Atakujący może uzyskać dostęp do plików, zmodyfikować je lub wykraść sekrety środowiskowe i klucze API, działając z uprawnieniami użytkownika goose.
Rekomendacja
Zaktualizuj goose do wersji 1.44.0 lub nowszej, która zawiera poprawkę.
Inne podatności w goose
Zobacz wszystkie- CVE-2026-111079Wysokie
W Goose wykryto lukę. Gdy funkcja integracji z terminalem jest włączona, aplikacja przechwytuje historię poleceń powłoki i wysyła ją dosłownie, bez sanityzacji, do skonfigurowanych punktów końcowych dostawcy dużego modelu językowego (LLM) podczas zapytań. Jeśli użytkownik wprowadzi w terminalu poufne dane, takie jak tokeny API, hasła lub zmienne środowiskowe zawierające sekrety, te nieocenzurowane informacje są przesyłane przez granice zaufania.
- CVE-2026-109561Średnie
W goose od wersji 1.28.0 do 1.44.0 występuje luka obejścia autoryzacji, która pozwala narzędziom działać bez zgody użytkownika w trybie Manual Approval. Adnotacje read-only utrwalone w sesji nie są czyszczone przez update_goose_mode, więc po użyciu trybu Smart Approval wywołania narzędzi z adnotacją readOnlyHint: true wykonują się bez pytania, omijając wybrany tryb zatwierdzania w PermissionInspector::inspect.
- CVE-2026-85623Wysokie
goose 1.37.0 wykonuje dowolne polecenia z rozszerzeń stdio przepisów i retry.checks bez kontroli bezpieczeństwa. Atakujący mogą rozpowszechniać złośliwe przepisy, które wykonują polecenia powłoki jako użytkownik uruchamiający goose, omijając skan bezpieczeństwa przepisów, który nie sprawdza rozszerzeń ani konfiguracji ponowień.
Oryginalny opis (angielski, źródło NVD)
goose is general-purpose AI agent that runs on your machine. Prior to 1.44.0, the `goose review` command runs the system `git` executable to gather the diff for review without stripping attacker-controlled Git configuration. A malicious repository whose `.git/config` sets [`core] fsmonitor = <command>` causes Git to execute that command on the host during the index refresh performed by `git diff HEAD`. The command runs before goose contacts a model and without a submitted prompt, model call, tool approval, or trust prompt. The context-gathering Git process is not sandboxed and is outside goose's tool-permission model. Arbitrary commands run with the privileges and environment of the user running goose, allowing file access or modification and exfiltration of environment secrets and provider API keys. The vulnerable Git invocations are built by git_command() in crates/goose-cli/src/commands/review/handler.rs and are used by touched_files() and collect_diff() for `git diff --name-only HEAD` and `git diff HEAD`. This issue is fixed in version 1.44.0.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

