CVE-2026-47162
WysokieCVSS 8.8Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 18 - wyżej niż 18% wszystkich znanych CVE
Streszczenie
W Vimie przed wersją 9.2.0495 wykryto podatność na wstrzykiwanie kodu Vimscript w funkcji s:NetrwBookHistSave() wtyczki netrw. Nazwa katalogu pochodząca z systemu plików jest interpolowana do literału łańcuchowego Vimscript bez odpowiedniego escapowania apostrofów, co umożliwia wykonanie dowolnego kodu Vimscript, w tym poleceń powłoki, przy następnym wczytaniu pliku historii.
Ocena ryzyka
Atakujący może umieścić spreparowaną nazwę katalogu w systemie plików, która po odwiedzeniu przez użytkownika Vima spowoduje wykonanie dowolnego kodu Vimscript, a w konsekwencji przejęcie kontroli nad sesją edytora i potencjalnie całym systemem.
Rekomendacja
Należy natychmiast zaktualizować Vima do wersji 9.2.0495 lub nowszej. Jeśli aktualizacja nie jest możliwa, należy tymczasowo wyłączyć wtyczkę netrw lub unikać przeglądania katalogów za pomocą Vima.
Inne podatności w Vim
Zobacz wszystkie- CVE-2026-41411Średnie
Vim to otwartoźródłowy edytor tekstu wiersza poleceń. W wersjach przed 9.2.0357 istnieje podatność na wstrzyknięcie poleceń w przetwarzaniu plików tagów. Podczas rozwiązywania tagu pole nazwy pliku jest poddawane ekspansji symboli wieloznacznych; jeśli zawiera składnię backtick (np. `command`), Vim wykonuje osadzone polecenie przez powłokę systemową z pełnymi uprawnieniami użytkownika.
- CVE-2026-28422Niskie
Vim to otwartoźródłowy edytor tekstu wiersza poleceń. W wersjach przed 9.2.0078 występuje przepełnienie bufora stosu w funkcji `build_stl_str_hl()` podczas renderowania linii statusu z wielobajtowym znakiem wypełnienia na bardzo szerokim terminalu. Wersja 9.2.0078 naprawia ten problem.
- CVE-2026-28421Średnie
Vim w wersjach przed 9.2.0077 ma przepełnienie bufora sterty i błąd segmentacji (SEGV) w logice odzyskiwania pliku swap. Oba problemy wynikają z niezwalidowanych pól odczytywanych ze spreparowanych bloków wskaźników w pliku swap.
- CVE-2026-28420Średnie
Vim, otwartoźródłowy edytor tekstu wiersza poleceń, w wersjach przed 9.2.0076 zawiera przepełnienie bufora oparte na stercie (zapis) oraz odczyt poza granicami bufora w emulatorze terminala podczas przetwarzania maksymalnej liczby znaków łączących z dodatkowych płaszczyzn Unicode. Wersja 9.2.0076 naprawia ten problem.
- CVE-2026-28419Średnie
W Vim przed wersją 9.2.0075 istnieje podczytanie poza bufor (heap-based buffer underflow) w logice parsowania plików tags w stylu Emacs. Przy przetwarzaniu zniekształconego pliku tags, w którym separator występuje na początku linii, Vim próbuje odczytać pamięć bezpośrednio przed zaalokowanym buforem.
- CVE-2026-28418Średnie
Vim jest podatny na przepełnienie bufora oparte na stercie i odczyt poza granicami w logice parsowania plików tagów w stylu Emacs przed wersją 9.2.0074. Przetwarzając złośliwy plik tagów, Vim może odczytać do 7 bajtów poza przydzieloną pamięcią. Wersja 9.2.0074 naprawia problem.
- CVE-2026-28417Średnie
W wtyczce netrw dołączanej do edytora Vim istnieje luka umożliwiająca wstrzyknięcie poleceń systemu operacyjnego. Otwarcie spreparowanego adresu URL (np. przez obsługę protokołu scp://) pozwala atakującemu na wykonanie dowolnych poleceń powłoki z uprawnieniami procesu Vim. Problem naprawiono w wersji 9.2.0073.
- CVE-2026-26269Średnie
W integracji NetBeans w Vimie istnieje przepełnienie bufora stosu podczas przetwarzania polecenia specialKeys. Złośliwy serwer NetBeans może przepełnić 64-bajtowy bufor keybuf pojedynczym poleceniem specialKeys. Problem naprawiono w wersji 9.1.2148.
- CVE-2024-22667Wysokie
W edytorze Vim w wersjach przed 9.0.2142 występuje przepełnienie bufora na stosie, ponieważ funkcja did_set_langmap w pliku map.c używa sprintf do zapisu do bufora błędu przekazywanego do funkcji zwrotnych opcji.
- CVE-2017-11109Wysokie
Vim 8.0 pozwala atakującym na spowodowanie odmowy usługi (nieważne zwolnienie pamięci) lub potencjalnie innego nieokreślonego wpływu poprzez spreparowany plik źródłowy (znany jako -S).
Oryginalny opis (angielski, źródło NVD)
Vim is an open source, command line text editor. Prior to version 9.2.0495, a Vimscript code injection vulnerability exists in s:NetrwBookHistSave() in the netrw plugin (runtime/pack/dist/opt/netrw/autoload/netrw.vim) when serializing browsed directory paths to the history file ~/.vim/.netrwhist. A directory name derived from the filesystem is interpolated into a single-quoted Vimscript string literal without escaping embedded single quotes, allowing a crafted directory name to break out of the string context and execute arbitrary Vimscript, including shell commands via system() and :!, the next time the history file is sourced. This issue has been patched in version 9.2.0495.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

