Katalog CVE

CVE-2026-44580

ŚrednieCVSS 6.1
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.21%

Percentyl 10 - wyżej niż 10% wszystkich znanych CVE

Streszczenie

Next.js to framework React do budowy aplikacji full-stack. W wersjach od 13.0.0 do przed 15.5.16 oraz 16.2.5 aplikacje używające skryptów beforeInteractive wraz z niezaufaną treścią mogą być podatne na cross-site scripting. W podatnych wersjach serializowana treść skryptu nie była bezpiecznie escapowana przed osadzeniem w dokumencie, co mogło pozwolić danym kontrolowanym przez atakującego na wyjście z zamierzonego kontekstu skryptu i wykonanie dowolnego JavaScriptu w przeglądarce odwiedzającego.

Ocena ryzyka

Atakujący może wykonać dowolny JavaScript w przeglądarce użytkownika, co może prowadzić do kradzieży sesji lub innych działań w imieniu ofiary. Ryzyko dotyczy aplikacji przetwarzających niezaufaną treść.

Rekomendacja

Zaktualizuj Next.js do wersji 15.5.16 lub 16.2.5. Unikaj osadzania niezaufanej treści w skryptach beforeInteractive.

Inne podatności w Next.js

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS