Katalog CVE

CVE-2026-42509

ŚrednieCVSS 6.1
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.36%

Percentyl 29 - wyżej niż 29% wszystkich znanych CVE

Streszczenie

Apache Wicket zawiera podatność typu Cross-site Scripting (XSS) wynikającą z niewłaściwej neutralizacji danych wejściowych podczas generowania stron WWW. Problem dotyczy wersji od 8.0.0 do 8.17.0, 9.0.0 oraz od 10.0.0 do 10.8.0.

Ocena ryzyka

Atakujący może wstrzyknąć złośliwy skrypt wykonywany w przeglądarce użytkownika, co może prowadzić do kradzieży sesji lub danych.

Rekomendacja

Zaktualizuj Apache Wicket do wersji 10.9.0, która naprawia tę podatność.

Inne podatności w Apache Wicket

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS