Katalog CVE

CVE-2026-41636

WysokieCVSS 7.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.45%

Percentyl 39 - wyżej niż 39% wszystkich znanych CVE

Streszczenie

Wiązania Node.js Apache Thrift przed wersją 0.23.0 zawierają podatność na niekontrolowaną rekurencję. Może to prowadzić do wyczerpania zasobów lub awarii aplikacji przy przetwarzaniu specjalnie spreparowanych danych.

Ocena ryzyka

Aplikacje korzystające z biblioteki Apache Thrift dla Node.js mogą ulec awarii lub stać się niedostępne w wyniku ataku denial-of-service. Ryzyko dotyczy dostępności usług.

Rekomendacja

Zaktualizuj Apache Thrift do wersji 0.23.0, która naprawia tę podatność.

Inne podatności w Apache Thrift

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS