CVE-2026-2996
WysokieCVSS 7.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 43 - wyżej niż 43% wszystkich znanych CVE
Streszczenie
Wtyczka Advanced Product Fields (Product Addons) dla WooCommerce w WordPressie jest podatna na nieprawidłową walidację danych wejściowych we wszystkich wersjach do 1.6.21 włącznie. Wynika to z błędu logicznego w funkcji 'validate_cart_data'. Umożliwia to nieuwierzytelnionym atakującym ominięcie wymaganych płatnych dodatków i dokonanie zakupów tylko po cenie bazowej produktu, skutecznie kradnąc produkty, płacąc ułamek zamierzonej ceny. Podatność została częściowo załatana w wersji 1.6.19.
Ocena ryzyka
Ryzyko strat finansowych i kradzieży produktów, ponieważ atakujący mogą kupować produkty bez płacenia za wymagane dodatki.
Rekomendacja
Zaktualizuj wtyczkę Advanced Product Fields do najnowszej wersji, która zawiera pełną poprawkę. Sprawdź, czy nie ma nieautoryzowanych zamówień.
Powiązane podatności
- CVE-2026-123614Krytyczne
W imgproxy od wersji 4.0.0 do 4.0.16 występuje przepełnienie liczb całkowitych w loaderze ICO, które pozwala zdalnym atakującym wywołać przepełnienie bufora sterty poprzez spreparowaną wartość data_size. Atakujący może przesłać spreparowany obraz ICO, w którym data_size powoduje zawinięcie alokacji w vips/icoload.c, uszkadzając pamięć sterty, co prowadzi do awarii procesu lub wykonania kodu.
- CVE-2026-123551Krytyczne
OpenAM od wersji 14.0.0 do 16.1.4 zawiera podatność na ujawnienie informacji, która pozwala nieuwierzytelnionym atakującym odczytać aktywne tokeny sesji z WebSocketu powiadomień. Atakujący mogą obejść sprawdzenie przeznaczone tylko dla agentów poprzez niezwalidowane wewnętrzne przekierowanie na starszych punktach końcowych Liberty ID-FF, zbierając tokeny iPlanetDirectoryPro w celu przejęcia sesji użytkowników i administratorów.
- CVE-2026-123550Krytyczne
OpenAM przed wersją 16.1.4 zawiera podatność na obejście uwierzytelniania w usłudze SAML v2.0 service provider, która akceptuje niepodpisane asercje w powiązaniach ECP (PAOS) i HTTP-Artifact, gdy WantAssertionsSigned ma wartość false. Nieuwierzytelnieni zdalni atakujący mogą przesłać sfałszowane asercje, aby uzyskać sesje jako dowolny zmapowany użytkownik, w tym administrator, i przejąć logowanie jednokrotne do aplikacji zależnych.
- CVE-2026-123549Krytyczne
OpenAM przed wersją 16.1.4 nie egzekwuje listy Valid Creation Attributes podczas samodzielnej rejestracji, co pozwala anonimowym atakującym ustawić zastrzeżone atrybuty, w tym członkostwo w grupach. Atakujący mogą zarejestrować się przez starszy punkt końcowy REST samoobsługi lub przepływ User Self-Service, aby dołączyć do grup administracyjnych i uzyskać pełną kontrolę administracyjną nad OpenAM.
- CVE-2026-124060Krytyczne
W urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884 wykryto podatność w funkcji UploadCustomModule w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem File prowadzi do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit jest publicznie dostępny i może być wykorzystany.
- CVE-2026-124059Krytyczne
Wykryto podatność bezpieczeństwa w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiWdsAddConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr prowadzi do przepełnienia bufora. Atak można zainicjować zdalnie, a exploit został publicznie ujawniony i może być wykorzystany.
- CVE-2026-124058Krytyczne
Zidentyfikowano słabość w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiRepeaterConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr może prowadzić do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit został udostępniony publicznie i może być wykorzystany w atakach.
- CVE-2026-124057Krytyczne
W TOTOLINK CA300-PoE 6.2c.884 odkryto lukę w zabezpieczeniach funkcji setWiFiMultipleConfig w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem Key1Str1 prowadzi do przepełnienia bufora, a atak można zainicjować zdalnie. Exploit został publicznie udostępniony i może być wykorzystany.
- CVE-2026-123966Krytyczne
W urządzeniu Tenda AC19 w wersji 16.03.10.07 wykryto podatność w funkcji saveParentControlInfo w pliku /goform/saveParentControlInfo. Manipulacja argumentem deviceId powoduje przepełnienie bufora na stercie. Atak można przeprowadzić zdalnie, a exploit został publicznie ujawniony.
- CVE-2026-120984Krytyczne
W komponencie zarządzania klientami serwera Keycloak wykryto błąd. Podczas tworzenia lub importu klienta z włączonymi usługami autoryzacji system nie czyści prawidłowo atrybutu sesji używanego podczas konfiguracji. Uwierzytelniony atakujący z uprawnieniami do zarządzania klientami może ominąć mechanizmy bezpieczeństwa i przesłać złośliwą politykę JavaScript, która jest wykonywana na serwerze.
Oryginalny opis (angielski, źródło NVD)
The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

