CVE-2026-28214
ŚrednieCVSS 6.5Prawdopodobieństwo exploitacji (EPSS)
Podwyższone ryzykoPercentyl 66 - wyżej niż 66% wszystkich znanych CVE
Streszczenie
W Firebird, otwartoźródłowym systemie zarządzania bazami danych, w wersjach przed 5.0.4, 4.0.7 i 3.0.14 funkcja ClumpletReader::getClumpletSize() może spowodować przepełnienie wartości totalLength podczas parsowania clumpletu typu Wide, prowadząc do nieskończonej pętli. Uwierzytelniony użytkownik z uprawnieniami INSERT na dowolnej tabeli może to wykorzystać poprzez spreparowany Batch Parameter Block, powodując odmowę usługi na serwerze. Problem naprawiono w wersjach 5.0.4, 4.0.7 i 3.0.14.
Ocena ryzyka
Uwierzytelniony atakujący może spowodować zawieszenie lub niedostępność serwera bazy danych, zakłócając działanie aplikacji. Może to prowadzić do przerw w świadczeniu usług i utraty produktywności.
Rekomendacja
Zaktualizuj Firebird do wersji 5.0.4, 4.0.7 lub 3.0.14 (lub nowszej). Ogranicz uprawnienia INSERT do niezbędnych użytkowników i monitoruj nietypowe zapytania.
Inne podatności w Firebird
Zobacz wszystkie- CVE-2007-2606Wysokie
Wielokrotne przepełnienia bufora w Firebird 2.1 umożliwiają atakującym wywołanie uszkodzenia pamięci poprzez przetworzenie specjalnie spreparowanych danych w plikach config\ConfigFile.cpp lub msgs\check_msgs.epp. Może to prowadzić do nieokreślonych skutków, w tym potencjalnie do wykonania kodu.
- CVE-2014-9323Średnie
W Firebirdzie przed wersjami 2.1.7 i 2.5.3 SU1 funkcja xdr_status_vector pozwala zdalnym atakującym wywołać odmowę usługi (przez dereferencję wskaźnika NULL, błąd segmentacji i awarię) za pomocą akcji op_response z niepustym statusem.
Oryginalny opis (angielski, źródło NVD)
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the ClumpletReader::getClumpletSize() function can overflow the totalLength value when parsing a Wide type clumplet, causing an infinite loop. An authenticated user with INSERT privileges on any table can exploit this via a crafted Batch Parameter Block to cause a denial of service against the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

