CVE-2026-25125
ŚrednieCVSS 4.9Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 25 - wyżej niż 25% wszystkich znanych CVE
Streszczenie
October CMS przed wersjami 3.7.14 i 4.1.10 zawiera podatność na ujawnienie informacji po stronie serwera w parserze ustawień INI. PHP parse_ini_string() obsługuje składnię ${} dla zmiennych środowiskowych, co pozwala atakującym z dostępem edytora na wstrzykiwanie wzorców, takich jak ${APP_KEY}, co prowadzi do ujawnienia wrażliwych zmiennych środowiskowych.
Ocena ryzyka
Ryzyko obejmuje wyciek danych uwierzytelniających i sekretów (hasła baz danych, klucze AWS, klucze aplikacji), co może umożliwić dalsze ataki, takie jak dostęp do bazy danych lub fałszowanie ciasteczek.
Rekomendacja
Należy zaktualizować October CMS do wersji 3.7.14 lub 4.1.10. Jeśli aktualizacja nie jest możliwa, ogranicz dostęp narzędzi edytora tylko do zaufanych administratorów.
Inne podatności w October CMS
Zobacz wszystkie- CVE-2026-101005Wysokie
Wykryto podatność w October CMS do wersji 4.3.4. Dotyczy funkcji validateExternalImageHost w pliku System/Classes/ResizeImages.php w komponencie SSRF Protection. Manipulacja prowadzi do podatności Server-Side Request Forgery (SSRF). Atak może być przeprowadzony zdalnie, a exploit jest publicznie dostępny.
- CVE-2017-16941Wysokie
October CMS w wersji do 1.0.428 nie blokuje użycia plików .htaccess w motywach, co pozwala zdalnym uwierzytelnionym użytkownikom na wykonanie dowolnego kodu PHP poprzez pobranie archiwum ZIP motywu z /backend/cms/themes, a następnie przesłanie i zaimportowanie zmodyfikowanego archiwum z dwoma nowymi plikami: plikiem .php i .htaccess.
- CVE-2017-1000195Wysokie
Wersja 412 systemu October CMS jest podatna na wstrzykiwanie obiektów PHP w funkcjonalności przenoszenia zasobów, co umożliwia usuwanie plików ograniczonych przez uprawnienia plików na serwerze.
- CVE-2017-1000119Wysokie
October CMS w wersji 412 jest podatny na wykonanie kodu PHP w funkcjonalności przesyłania plików, co może prowadzić do kompromitacji strony oraz potencjalnie innych aplikacji na serwerze.
- CVE-2021-32648WysokieAktywnie exploitowane
Podatność w pakiecie october/system platformy October CMS pozwala atakującemu na żądanie resetu hasła konta, a następnie uzyskanie dostępu do konta za pomocą specjalnie spreparowanego żądania. Problem został naprawiony w Build 472 i wersji 1.1.5.
- CVE-2017-1000197Krytyczne
October CMS w wersji 412 jest podatny na modyfikację ścieżki pliku w funkcjonalności przenoszenia zasobów, co może prowadzić do tworzenia złośliwych plików na serwerze.
- CVE-2017-1000196Krytyczne
October CMS w wersji 412 jest podatny na wykonanie kodu PHP w funkcjonalności menedżera zasobów, co może prowadzić do kompromitacji strony oraz potencjalnie innych aplikacji na serwerze.
- CVE-2017-1000194Krytyczne
Wersja 412 systemu October CMS jest podatna na modyfikację konfiguracji Apache poprzez funkcjonalność przesyłania plików, co może prowadzić do kompromitacji strony oraz innych aplikacji na serwerze.
- CVE-2026-49400Niskie
October CMS w wersjach przed 3.7.17 i 4.2.21 zawiera podatność na iniekcję obiektów PHP w module systemowym. Backendowy trait `SessionMaker` przechowywał stan sesji widgetów jako `base64(serialize(...))` i odczytywał go przez `unserialize()` bez ograniczenia `allowed_classes`, co umożliwiało atakującemu wstrzyknięcie zserializowanych danych i wywołanie łańcuchów gadżetów PHP. Problem dotyczy tylko instalacji z włączonym trybem Safe Mode, który jest opcjonalny i stosowany głównie w scenariuszach z niezaufanymi użytkownikami.
- CVE-2026-46696Niskie
Podatność w module systemu October CMS dotyczy polityki bezpieczeństwa sandboxa Twig, gdy włączony jest tryb cms.safe_mode. Poprzez łańcuch obejść można było uzyskać dostęp do magazynu sesji Laravel oraz surowych metod SQL, co pozwalało użytkownikowi backendu z uprawnieniami do edycji znaczników CMS odczytywać dowolne dane z bazy i podszyć się pod sesję innego użytkownika. Luka została naprawiona w wersjach 3.7.17 i 4.2.21.
Oryginalny opis (angielski, źródło NVD)
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a server-side information disclosure vulnerability in the INI settings parser. Because PHP's parse_ini_string() function supports ${} syntax for environment variable interpolation, attackers with Editor access could inject patterns such as ${APP_KEY} or ${DB_PASSWORD} into CMS page settings fields, causing sensitive environment variables to be resolved, stored in the template, and returned to the attacker when the page was reopened. This could enable exfiltration of credentials and secrets (database passwords, AWS keys, application keys), potentially leading to further attacks such as database access or cookie forgery. The vulnerability is only relevant when cms.safe_mode is enabled, as direct PHP injection is already possible otherwise. This issue has been fixed in versions 3.7.14 and 4.1.10. If users are unable to immediately upgrade, they can workaround this issue by restricting Editor tool access to fully trusted administrators only, and ensuring database and cloud service credentials are not accessible from the web server's network.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

