Katalog CVE

CVE-2026-24906

ŚrednieCVSS 5.4
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.25%

Percentyl 17 - wyżej niż 17% wszystkich znanych CVE

Streszczenie

October CMS w wersjach przed 3.7.14 i 4.1.10 zawiera podatność Stored XSS w ustawieniach edytora backendu. Pola Markup Classes (używane do stylów akapitów, stylów inline, stylów tabel itp.) nie sanityzowały danych wejściowych do prawidłowych znaków nazw klas CSS. Złośliwe wartości były renderowane bez sanityzacji w menu rozwijanych edytora Froala, umożliwiając wykonanie JavaScriptu, gdy użytkownik otworzył RichEditor. Może to prowadzić do eskalacji uprawnień, jeśli superużytkownik otworzy RichEditor podczas rutynowej edycji treści, i wymaga uwierzytelnionego dostępu do backendu z uprawnieniami do ustawień edytora.

Ocena ryzyka

Atakujący z dostępem do backendu może wykonać złośliwy skrypt w przeglądarce superużytkownika, przejmując jego sesję i eskalując uprawnienia, co może prowadzić do pełnej kompromitacji systemu CMS.

Rekomendacja

Zaktualizuj October CMS do wersji 3.7.14 lub 4.1.10. Jako obejście, ogranicz uprawnienia do ustawień edytora wyłącznie do w pełni zaufanych administratorów.

Inne podatności w October CMS

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a Stored Cross-Site Scripting (XSS) vulnerability in the Backend Editor Settings. The Markup Classes fields (used for paragraph styles, inline styles, table styles, etc.) did not sanitize input to valid CSS class name characters. Malicious values were rendered unsanitized in Froala editor dropdown menus, allowing JavaScript execution when any user opened a RichEditor. Exploitation could lead to privilege escalation if a superuser opens any RichEditor during routine content editing (e.g., editing a blog post), and requires authenticated backend access with editor settings permissions. This issue has been fixed in versions 3.7.14 and 4.1.10. To workaround this issue, restrict editor settings permissions to fully trusted administrators only

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS