CVE-2026-24895
KrytyczneStreszczenie
FrankenPHP to nowoczesny serwer aplikacji dla PHP. W wersjach przed 1.11.2 logika dzielenia ścieżki CGI niewłaściwie obsługuje znaki Unicode podczas konwersji wielkości liter, co może prowadzić do wykonania niewłaściwego pliku.
Ocena ryzyka
Organizacja może być narażona na wykonanie nieautoryzowanych skryptów, co może prowadzić do poważnych naruszeń bezpieczeństwa i utraty danych.
Rekomendacja
Zaleca się aktualizację FrankenPHP do wersji 1.11.2 lub nowszej, aby usunąć tę podatność.
Powiązane podatności
- CVE-2026-123614Krytyczne
W imgproxy od wersji 4.0.0 do 4.0.16 występuje przepełnienie liczb całkowitych w loaderze ICO, które pozwala zdalnym atakującym wywołać przepełnienie bufora sterty poprzez spreparowaną wartość data_size. Atakujący może przesłać spreparowany obraz ICO, w którym data_size powoduje zawinięcie alokacji w vips/icoload.c, uszkadzając pamięć sterty, co prowadzi do awarii procesu lub wykonania kodu.
- CVE-2026-123551Krytyczne
OpenAM od wersji 14.0.0 do 16.1.4 zawiera podatność na ujawnienie informacji, która pozwala nieuwierzytelnionym atakującym odczytać aktywne tokeny sesji z WebSocketu powiadomień. Atakujący mogą obejść sprawdzenie przeznaczone tylko dla agentów poprzez niezwalidowane wewnętrzne przekierowanie na starszych punktach końcowych Liberty ID-FF, zbierając tokeny iPlanetDirectoryPro w celu przejęcia sesji użytkowników i administratorów.
- CVE-2026-123550Krytyczne
OpenAM przed wersją 16.1.4 zawiera podatność na obejście uwierzytelniania w usłudze SAML v2.0 service provider, która akceptuje niepodpisane asercje w powiązaniach ECP (PAOS) i HTTP-Artifact, gdy WantAssertionsSigned ma wartość false. Nieuwierzytelnieni zdalni atakujący mogą przesłać sfałszowane asercje, aby uzyskać sesje jako dowolny zmapowany użytkownik, w tym administrator, i przejąć logowanie jednokrotne do aplikacji zależnych.
- CVE-2026-123549Krytyczne
OpenAM przed wersją 16.1.4 nie egzekwuje listy Valid Creation Attributes podczas samodzielnej rejestracji, co pozwala anonimowym atakującym ustawić zastrzeżone atrybuty, w tym członkostwo w grupach. Atakujący mogą zarejestrować się przez starszy punkt końcowy REST samoobsługi lub przepływ User Self-Service, aby dołączyć do grup administracyjnych i uzyskać pełną kontrolę administracyjną nad OpenAM.
- CVE-2026-124060Krytyczne
W urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884 wykryto podatność w funkcji UploadCustomModule w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem File prowadzi do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit jest publicznie dostępny i może być wykorzystany.
- CVE-2026-124059Krytyczne
Wykryto podatność bezpieczeństwa w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiWdsAddConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr prowadzi do przepełnienia bufora. Atak można zainicjować zdalnie, a exploit został publicznie ujawniony i może być wykorzystany.
- CVE-2026-124058Krytyczne
Zidentyfikowano słabość w urządzeniu TOTOLINK CA300-PoE w wersji 6.2c.884. Podatna jest funkcja setWiFiRepeaterConfig w pliku /cgi-bin/cstecgi.cgi, gdzie manipulacja argumentem ApCliKeyStr może prowadzić do przepełnienia bufora. Atak można przeprowadzić zdalnie, a exploit został udostępniony publicznie i może być wykorzystany w atakach.
- CVE-2026-124057Krytyczne
W TOTOLINK CA300-PoE 6.2c.884 odkryto lukę w zabezpieczeniach funkcji setWiFiMultipleConfig w pliku /cgi-bin/cstecgi.cgi. Manipulacja argumentem Key1Str1 prowadzi do przepełnienia bufora, a atak można zainicjować zdalnie. Exploit został publicznie udostępniony i może być wykorzystany.
- CVE-2026-123966Krytyczne
W urządzeniu Tenda AC19 w wersji 16.03.10.07 wykryto podatność w funkcji saveParentControlInfo w pliku /goform/saveParentControlInfo. Manipulacja argumentem deviceId powoduje przepełnienie bufora na stercie. Atak można przeprowadzić zdalnie, a exploit został publicznie ujawniony.
- CVE-2026-120984Krytyczne
W komponencie zarządzania klientami serwera Keycloak wykryto błąd. Podczas tworzenia lub importu klienta z włączonymi usługami autoryzacji system nie czyści prawidłowo atrybutu sesji używanego podczas konfiguracji. Uwierzytelniony atakujący z uprawnieniami do zarządzania klientami może ominąć mechanizmy bezpieczeństwa i przesłać złośliwą politykę JavaScript, która jest wykonywana na serwerze.
Oryginalny opis (angielski, źródło NVD)
FrankenPHP is a modern application server for PHP. Prior to 1.11.2, FrankenPHP’s CGI path splitting logic improperly handles Unicode characters during case conversion. The logic computes the split index (for finding .php) on a lowercased copy of the request path but applies that byte index to the original path. Because strings.ToLower() in Go can increase the byte length of certain UTF-8 characters (e.g., Ⱥ expands when lowercased), the computed index may not align with the correct position in the original string. This results in an incorrect SCRIPT_NAME and SCRIPT_FILENAME, potentially causing FrankenPHP to execute a file other than the one intended by the URI. This vulnerability is fixed in 1.11.2.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

