CVE-2026-24734
WysokieCVSS 7.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 39 - wyżej niż 39% wszystkich znanych CVE
Streszczenie
Podatność w Apache Tomcat Native i Apache Tomcat związana z nieprawidłową walidacją danych wejściowych podczas korzystania z respondera OCSP. Brak pełnej weryfikacji i sprawdzania świeżości odpowiedzi OCSP umożliwia ominięcie sprawdzania ważności certyfikatów.
Ocena ryzyka
Atakujący może wykorzystać tę podatność do użycia unieważnionego certyfikatu, co prowadzi do naruszenia zaufania i potencjalnego przejęcia kontroli nad komunikacją TLS.
Rekomendacja
Zaleca się aktualizację Apache Tomcat Native do wersji 1.3.5 lub nowszej albo 2.0.12 lub nowszej, a Apache Tomcat do wersji 11.0.18, 10.1.52 lub 9.0.115 lub nowszej.
Inne podatności w Apache Tomcat Native
Zobacz wszystkie- CVE-2026-86246Krytyczne
Podatność polegająca na inicjalizacji zasobu z niebezpiecznym domyślnym ustawieniem w Apache Tomcat Native włączała niebezpieczne opcje domyślnie, w tym ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF i ALLOW_NO_DHE_KEX. Problem dotyczy Apache Tomcat Native od 2.0.0 do 2.0.15 oraz od 1.3.0 do 1.3.8. Zaleca się aktualizację do wersji 2.0.16 lub 1.3.9.
- CVE-2026-86247Wysokie
Podatność typu wyścig (race condition) w Apache Tomcat Native umożliwia obniżenie wymagań weryfikacji certyfikatu klienta w niektórych konfiguracjach. Dotyczy wersji od 2.0.0 do 2.0.15 oraz od 1.3.0 do 1.3.8.
- CVE-2026-86243Wysokie
Podatność nadmiernego odczytu bufora (buffer over-read) w Apache Tomcat Native podczas uzgadniania TLS pozwala złośliwemu użytkownikowi wywołać DoS poprzez awarię JVM. Dotyczy wersji od 2.0.0 do 2.0.15 oraz od 1.3.0 do 1.3.8.
Oryginalny opis (angielski, źródło NVD)
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

