CVE-2026-119922
WysokieCVSS 8.8Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 46 - wyżej niż 46% wszystkich znanych CVE
Streszczenie
Nieprawidłowa kontrola dostępu w rozszerzeniu Babelfish for PostgreSQL (wersje 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4) oraz w Amazon Aurora PostgreSQL z Babelfish może pozwolić zdalnym uwierzytelnionym użytkownikom na podniesienie uprawnień.
Ocena ryzyka
Uwierzytelniony użytkownik może uzyskać wyższe uprawnienia w bazie danych, co może prowadzić do nieautoryzowanego dostępu do danych lub modyfikacji konfiguracji. Narusza to model kontroli dostępu organizacji.
Rekomendacja
Zaktualizuj rozszerzenie Babelfish for PostgreSQL do wersji 4.10, 5.6, 6.1 lub nowszej, a klastry Aurora PostgreSQL z Babelfish do zalecanych wersji. Zastosuj również oczekujące aktualizacje, aby zapewnić najnowsze poprawki.
Inne podatności w Babelfish for PostgreSQL
Zobacz wszystkie- CVE-2026-119924Wysokie
Podatność typu out-of-bounds read w parserze nazw procedur TDS RPC w rozszerzeniu Babelfish for PostgreSQL (wersje 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4) oraz w Amazon Aurora PostgreSQL z Babelfish. Zdalny uwierzytelniony użytkownik może odczytać sąsiednią pamięć procesu lub spowodować odmowę usługi poprzez wysłanie złośliwego żądania TDS RPC na port TDS (domyślnie 1433).
- CVE-2026-119923Krytyczne
Przepełnienie bufora na stercie w parserze prelogin TDS w rozszerzeniu Babelfish for PostgreSQL (wersje 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4) oraz w Amazon Aurora PostgreSQL z Babelfish może pozwolić zdalnym atakującym na wykonanie dowolnych poleceń systemu operacyjnego jako użytkownik procesu bazy danych poprzez specjalnie spreparowany zniekształcony pakiet prelogin TDS wysłany na port TDS. Rekord obejmuje również powiązane znalezisko dereferencji wskaźnika NULL w tym samym parserze.
Oryginalny opis (angielski, źródło NVD)
Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

