Katalog CVE

CVE-2026-112105

NiskieCVSS 3.7
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.34%

Percentyl 26 - wyżej niż 26% wszystkich znanych CVE

Streszczenie

W aplikacji GlitterWare Passy do wersji 1.10.1 wykryto podatność w funkcji MyHttpOverrides w pliku lib/main.dart w komponencie obsługi TLS. Manipulacja prowadzi do niewłaściwej walidacji certyfikatu, a atak można przeprowadzić zdalnie, choć charakteryzuje się wysoką złożonością i jest trudny w wykorzystaniu. Aktualizacja do wersji 1.10.2 rozwiązuje problem (poprawka 3d48df7cce05e39fa4de1e42768492307f26882e).

Ocena ryzyka

Niewłaściwa walidacja certyfikatu może umożliwić atakującemu przechwycenie lub podszycie się pod połączenie TLS, co prowadzi do wycieku danych lub działań w imieniu użytkownika. Ze względu na wysoką złożoność ataku ryzyko jest ograniczone, ale nadal istotne.

Rekomendacja

Zaktualizuj GlitterWare Passy do wersji 1.10.2 lub nowszej. Do czasu aktualizacji unikaj przetwarzania wrażliwych danych przez aplikację.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS