CVE-2026-108357
WysokieCVSS 8.8Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 20 - wyżej niż 20% wszystkich znanych CVE
Streszczenie
W bibliotece PhpSpreadsheet od wersji 3.3.0 do 3.10.8 i 5.10.0 czytnik Reader\Xml przepuszcza przechowywany XML SpreadsheetML przez XmlScanner::scan, a Xml::unentity dekoduje encje numeryczne dopiero po sprawdzeniu wzorca DOCTYPE. Podwójnie zakodowany znak mniejszości jest redukowany do dosłownego znaku mniejszości, więc SimpleXML otrzymuje niesprawdzony DOCTYPE i deklarację encji.
Ocena ryzyka
Przetwarzanie spreparowanego XML SpreadsheetML może spowodować atak denial of service przez rozwinięcie encji, a na PHP przed 8.0 lub przy włączonym LIBXML_NOENT umożliwić dostęp do plików lokalnych lub SSRF. Ryzyko dotyczy aplikacji przetwarzających niezaufane pliki SpreadsheetML.
Rekomendacja
Zaktualizuj PhpSpreadsheet do wersji 3.10.8 lub 5.10.0 (lub nowszej). Do czasu aktualizacji ogranicz przetwarzanie niezaufanych plików SpreadsheetML i unikaj włączania LIBXML_NOENT.
Inne podatności w PhpSpreadsheet
Zobacz wszystkie- CVE-2026-45034Krytyczne
PhpSpreadsheet przed wersją 1.30.5 zawierał lukę, która pozwalała na obejście zabezpieczeń związanych z obsługą wrapperów strumieniowych, co mogło prowadzić do zdalnego wykonania kodu (RCE). Problem wynikał z niewłaściwego sprawdzania schematu URL, co umożliwiało atakującym wykorzystanie wrapperów takich jak phar://.
- CVE-2026-34084Krytyczne
PhpSpreadsheet w wielu wersjach (do 1.30.2, 2.0.0-2.1.14, 2.2.0-2.4.3, 3.3.0-3.10.3, 4.0.0-5.5.0) jest podatny na zdalne wykonanie kodu (RCE) poprzez kontrolowany przez użytkownika argument filename w IOFactory::load(). Atakujący może podać ścieżkę strumienia PHP (np. phar://, ftp://, ssh2.sftp://), która przechodzi kontrolę is_file() w File::assertFile(). Wrapper phar:// wyzwala deserializację metadanych PHAR, co może prowadzić do RCE, jeśli dostępny jest odpowiedni gadżet.
- CVE-2026-108360Średnie
PhpSpreadsheet przed wersjami 1.30.7, 2.1.19, 2.4.8, 3.10.8 i 5.10.0 waliduje tylko początkowy adres URL zewnętrznego obrazu, nie stosując walidacji do przekierowań. Dozwolony host obrazu może przekierować serwer na adres wewnętrzny, powodując ślepe żądanie GET do wewnętrznych punktów końcowych, sieci lub metadanych chmury.
- CVE-2026-108359Wysokie
W bibliotece PhpSpreadsheet przed wersjami 1.30.7, 2.1.19, 2.4.8, 3.10.8 i 5.10.0 funkcja Ods::processTableRow przyjmuje nieograniczony atrybut table:number-rows-repeated z wiersza tabeli ODS. Gdy wiersz zawiera wartość, czytnik tworzy komórkę dla każdego powtórzenia bez sprawdzania limitu wierszy, więc mały plik ODS może zużyć dużo CPU i pamięci i zakończyć proces PHP.
- CVE-2026-108358Wysokie
W bibliotece PhpSpreadsheet przed wersjami 1.30.7, 2.1.19, 2.4.8, 3.10.8 i 5.10.0 funkcja XmlScanner::scan wykrywa DOCTYPE z uwzględnieniem bajtów NUL, ale nie sekwencji ucieczki ISO-2022 w częściach XML plików XLSX. Sekwencje te omijają skaner, a normalizacja kodowania usuwa bajty ucieczki przed parsowaniem, ujawniając prawidłowy DOCTYPE i definicje encji.
- CVE-2026-59932Wysokie
PhpSpreadsheet w wielu wersjach (4.0.0-5.8.0, 3.3.0-3.10.6, 2.2.0-2.4.6, 2.0.0-2.1.17 oraz wszystkie do 1.30.5) zawiera podatność w czytniku Gnumeric. Czytnik odczytuje dostarczone przez atakującego pliki .gnumeric do pamięci, a gdy plik zaczyna się od bajtów magicznych gzip, wywołuje gzdecode() na pełnej skompresowanej zawartości bez ograniczenia rozmiaru dekompresowanego pliku. Bardzo mały skompresowany plik .gnumeric może rozszerzyć się do danych większych niż limit pamięci PHP i spowodować awarię procesu podczas Gnumeric::canRead(), zanim plik zostanie odrzucony lub w pełni sparsowany. Podatność jest osiągalna przez normalne wykrywanie typu pliku i ścieżki ładowania Gnumeric, więc aplikacje akceptujące przesłane przez atakującego arkusze kalkulacyjne mogą ucierpieć z powodu odmowy usługi.
- CVE-2026-59933Wysokie
Biblioteka PhpSpreadsheet w wielu wersjach jest podatna na atak DoS poprzez odczyt plików OLE. Czytnik OLE podąża za łańcuchami sektorów z kontrolowanych przez atakującego metadanych XLS/OLE bez wykrywania cykli. Niewielki, złośliwy plik .xls może spowodować, że czytnik będzie wielokrotnie dołączał te same dane sektora, aż do wyczerpania pamięci PHP.
- CVE-2026-59931Wysokie
Biblioteka PhpSpreadsheet w wielu wersjach jest podatna na SSRF poprzez obejście białej listy domen funkcji WEBSERVICE(). Funkcja webService() waliduje host URL względem białej listy, ale PHP automatycznie podąża za przekierowaniami HTTP 301/302, a cel przekierowania nie jest ponownie walidowany. Atakujący może przesłać plik XLSX, który po obliczeniu formuły WEBSERVICE() spowoduje dostęp do dowolnych URL-i, w tym wewnętrznych adresów.
- CVE-2026-40902Wysokie
W bibliotece PhpSpreadsheet przed wersjami 1.30.4, 2.1.16, 2.4.5, 3.10.5 i 5.7.0 występuje podatność w metodzie ColumnAndRowAttributes::readRowAttributes(), która nie weryfikuje numerów wierszy w plikach XLSX względem maksymalnego limitu wierszy. Atakujący może stworzyć plik XLSX, który powoduje nadmierne obciążenie CPU podczas iteracji przez wiersze.
- CVE-2026-40863Wysokie
PhpSpreadsheet to biblioteka PHP do odczytu i zapisu plików arkuszy kalkulacyjnych. W wersjach przed 1.30.4, 2.1.16, 2.4.5, 3.10.5 i 5.7.0, czytnik XML SpreadsheetML nie weryfikuje atrybutu wiersza ss:Index względem maksymalnej dozwolonej liczby wierszy, co może prowadzić do wyczerpania CPU i odmowy usługi.
Oryginalny opis (angielski, źródło NVD)
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. From 3.3.0 until 3.10.8 and 5.10.0, Reader\Xml passes stored SpreadsheetML XML through XmlScanner::scan in Xml::canRead and Xml::trySimpleXMLLoadStringPrivate, while Xml::unentity decodes numeric entities only after each DOCTYPE pattern check. A double-encoded less-than character is reduced by the first callback to another encoded character and by the second callback to a literal less-than sign, so SimpleXML receives an unchecked DOCTYPE and entity declaration. Processing attacker-controlled SpreadsheetML XML can cause entity-expansion denial of service and can permit local file access or SSRF on PHP before 8.0 or when LIBXML_NOENT is enabled. This issue is fixed in versions 3.10.8 and 5.10.0.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

