CVE-2025-66454
ŚrednieCVSS 6.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 23 - wyżej niż 23% wszystkich znanych CVE
Streszczenie
Arcade MCP przed wersją 1.5.4 używa zakodowanego na stałe domyślnego sekretu workera ("dev"), który nie jest walidowany ani nadpisywany podczas normalnego uruchamiania serwera. W rezultacie nieuwierzytelniony atakujący znający ten domyślny klucz może sfałszować ważne tokeny JWT i całkowicie ominąć warstwę uwierzytelniania FastAPI, uzyskując zdalny dostęp do wszystkich punktów końcowych workera.
Ocena ryzyka
Nieuwierzytelniony atakujący może uzyskać pełny dostęp do punktów końcowych workera, w tym do wyliczania i wywoływania narzędzi, bez poświadczeń. Może to prowadzić do nieautoryzowanego dostępu i potencjalnych dalszych ataków.
Rekomendacja
Zaktualizuj Arcade MCP do wersji 1.5.4 lub nowszej. Upewnij się, że domyślne sekrety są zmieniane i walidowane podczas uruchamiania serwera.
Powiązane podatności
- CVE-2026-123294Krytyczne
W JetBrains Hub przed wersją 2026.2.52556 możliwe było podniesienie uprawnień poprzez zmianę danych uwierzytelniania e-mail w trakcie procesu weryfikacji.
- CVE-2026-123279Krytyczne
W JetBrains Datalore przed wersją 2026.4 możliwe było wykonanie kodu w obliczeniach notebooka przez współpracowników z uprawnieniami tylko do odczytu.
- CVE-2026-88800Krytyczne
Wtyczki WordPress MDJM Event Management i Mobile Events Manager do wersji 1.7.8.7 wykonują żądanie usunięcia roli przy każdym załadowaniu strony bez sprawdzenia uprawnień i bez nonce. Zabezpieczenie chroniące role z przypisanymi użytkownikami odczytuje inną część żądania niż ta, która wybiera usuwaną rolę, co pozwala nieuwierzytelnionym atakującym usunąć dowolną rolę WordPress, w tym administratora.
- CVE-2026-120844Krytyczne
Wtyczka miniOrange OAuth Single Sign On – SSO (OAuth Client) do wersji 7.1.3 zawiera podatność nieprawidłowego przypisania uprawnień, która umożliwia eskalację uprawnień.
- CVE-2026-119516Krytyczne
Wtyczka Radius Booking — Booking Calendar for Appointments & Services do wersji 1.0.20 zawiera podatność deserializacji niezaufanych danych, która umożliwia wstrzyknięcie obiektu.
- CVE-2026-118423Krytyczne
Wtyczka WordPress WP Libre Form w wersji 1.5.0.1 nie weryfikuje typu plików przesyłanych przez formularze, co pozwala nieuwierzytelnionym atakującym przesłać pliki PHP do lokalizacji dostępnej przez sieć i je wykonać, prowadząc do zdalnego wykonania kodu.
- CVE-2026-116533Krytyczne
Wtyczka WordPress Static Snapshot do wersji 0.2.1 włącznie nie sanityzuje metaznaków powłoki w wartości dostarczonej przez użytkownika przed dołączeniem jej do poleceń systemu operacyjnego wykonywanych przez serwer. Umożliwia to nieuwierzytelnionym atakującym wykonanie dowolnych poleceń na hoście.
- CVE-2026-63774Krytyczne
W projektancie raportów PowerSYSTEM Center występuje niewystarczająca walidacja danych wejściowych. Uwierzytelniony użytkownik może dzięki temu wykonywać nieautoryzowane polecenia SQL.
- CVE-2026-63017Krytyczne
W PowerSYSTEM Center występuje nieprawidłowa kontrola autoryzacji. Użytkownik z niskimi uprawnieniami może uzyskać dostęp do zasobów zarezerwowanych normalnie dla administratorów.
- CVE-2026-77596Krytyczne
W Kubeflow Pipelines przed wersją 2.18.0 punkty końcowe HTTP do przesyłania pipeline'ów i ich wersji nie wykonują kontroli SubjectAccessReview, gdy docelowa przestrzeń nazw jest pusta, a REQUIRE_NAMESPACE_FOR_PIPELINES domyślnie wynosi false. Użytkownik o niskich uprawnieniach może tworzyć współdzielone pipeline'y lub wstrzykiwać własne wersje do istniejących pipeline'ów bez wymaganych uprawnień zapisu. Jeśli serwer API jest bezpośrednio osiągalny bez proxy uwierzytelniającego, ten sam obejściowy mechanizm może wykorzystać nieuwierzytelniony wywołujący.
Oryginalny opis (angielski, źródło NVD)
Arcade MCP allows you to to create, deploy, and share MCP Servers. Prior to 1.5.4, the arcade-mcp HTTP server uses a hardcoded default worker secret ("dev") that is never validated or overridden during normal server startup. As a result, any unauthenticated attacker who knows this default key can forge valid JWTs and fully bypass the FastAPI authentication layer. This grants remote access to all worker endpoints—including tool enumeration and tool invocation—without credentials. This vulnerability is fixed in 1.5.4.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

