CVE-2025-66412
ŚrednieCVSS 5.4Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 34 - wyżej niż 34% wszystkich znanych CVE
Streszczenie
W Angularze, przed wersjami 21.0.2, 20.3.15 i 19.2.17, zidentyfikowano podatność typu Stored Cross-Site Scripting (XSS) w kompilatorze szablonów. Problem wynika z niekompletności wewnętrznego schematu zabezpieczeń kompilatora, co pozwala atakującym na obejście wbudowanej sanitizacji bezpieczeństwa Angulara.
Ocena ryzyka
Podatność ta umożliwia atakującym wstrzykiwanie złośliwych skryptów, co może prowadzić do kradzieży danych użytkowników lub przejęcia sesji. Organizacje korzystające z podatnych wersji Angulara są narażone na poważne zagrożenia bezpieczeństwa.
Rekomendacja
Zaleca się aktualizację do wersji 21.0.2, 20.3.15 lub 19.2.17, aby usunąć tę podatność. Należy również przeprowadzić audyt aplikacji w celu zidentyfikowania potencjalnych miejsc narażonych na ataki XSS.
Powiązane podatności
- CVE-2026-123294Krytyczne
W JetBrains Hub przed wersją 2026.2.52556 możliwe było podniesienie uprawnień poprzez zmianę danych uwierzytelniania e-mail w trakcie procesu weryfikacji.
- CVE-2026-123279Krytyczne
W JetBrains Datalore przed wersją 2026.4 możliwe było wykonanie kodu w obliczeniach notebooka przez współpracowników z uprawnieniami tylko do odczytu.
- CVE-2026-88800Krytyczne
Wtyczki WordPress MDJM Event Management i Mobile Events Manager do wersji 1.7.8.7 wykonują żądanie usunięcia roli przy każdym załadowaniu strony bez sprawdzenia uprawnień i bez nonce. Zabezpieczenie chroniące role z przypisanymi użytkownikami odczytuje inną część żądania niż ta, która wybiera usuwaną rolę, co pozwala nieuwierzytelnionym atakującym usunąć dowolną rolę WordPress, w tym administratora.
- CVE-2026-120844Krytyczne
Wtyczka miniOrange OAuth Single Sign On – SSO (OAuth Client) do wersji 7.1.3 zawiera podatność nieprawidłowego przypisania uprawnień, która umożliwia eskalację uprawnień.
- CVE-2026-119516Krytyczne
Wtyczka Radius Booking — Booking Calendar for Appointments & Services do wersji 1.0.20 zawiera podatność deserializacji niezaufanych danych, która umożliwia wstrzyknięcie obiektu.
- CVE-2026-118423Krytyczne
Wtyczka WordPress WP Libre Form w wersji 1.5.0.1 nie weryfikuje typu plików przesyłanych przez formularze, co pozwala nieuwierzytelnionym atakującym przesłać pliki PHP do lokalizacji dostępnej przez sieć i je wykonać, prowadząc do zdalnego wykonania kodu.
- CVE-2026-63774Krytyczne
W projektancie raportów PowerSYSTEM Center występuje niewystarczająca walidacja danych wejściowych. Uwierzytelniony użytkownik może dzięki temu wykonywać nieautoryzowane polecenia SQL.
- CVE-2026-63017Krytyczne
W PowerSYSTEM Center występuje nieprawidłowa kontrola autoryzacji. Użytkownik z niskimi uprawnieniami może uzyskać dostęp do zasobów zarezerwowanych normalnie dla administratorów.
- CVE-2026-77596Krytyczne
W Kubeflow Pipelines przed wersją 2.18.0 punkty końcowe HTTP do przesyłania pipeline'ów i ich wersji nie wykonują kontroli SubjectAccessReview, gdy docelowa przestrzeń nazw jest pusta, a REQUIRE_NAMESPACE_FOR_PIPELINES domyślnie wynosi false. Użytkownik o niskich uprawnieniach może tworzyć współdzielone pipeline'y lub wstrzykiwać własne wersje do istniejących pipeline'ów bez wymaganych uprawnień zapisu. Jeśli serwer API jest bezpośrednio osiągalny bez proxy uwierzytelniającego, ten sam obejściowy mechanizm może wykorzystać nieuwierzytelniony wywołujący.
- CVE-2026-119757Krytyczne
BTCPay Server przed 2.4.2 (w tym wersje release candidate 2.4.2) zawiera podatność ujawnienia informacji, która pozwala nieuwierzytelnionym zdalnym atakującym pobrać pliki poświadczeń .macaroon dla węzła LND. Ujawniony macaroon umożliwia pełną kontrolę nad węzłem LND, w tym przenoszenie środków, co prowadzi do kradzieży funduszy.
Oryginalny opis (angielski, źródło NVD)
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 21.0.2, 20.3.15, and 19.2.17, A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. This vulnerability is fixed in 21.0.2, 20.3.15, and 19.2.17.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

