Katalog CVE

CVE-2025-66040

NiskieCVSS 3.6
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.16%

Percentyl 4 - wyżej niż 4% wszystkich znanych CVE

Streszczenie

Biblioteka Spotipy (Python, Spotify Web API) w wersji przed 2.25.2 zawiera podatność XSS w serwerze callback OAuth. Parametr błędu nie jest sanityzowany, co pozwala na wstrzyknięcie i wykonanie dowolnego JavaScriptu w przeglądarce użytkownika podczas uwierzytelniania OAuth.

Ocena ryzyka

Atakujący może wykonać złośliwy kod JavaScript w kontekście przeglądarki użytkownika przechodzącego autoryzację OAuth, co może prowadzić do kradzieży tokenów lub danych sesji.

Rekomendacja

Zaktualizuj bibliotekę Spotipy do wersji 2.25.2 lub nowszej, która zawiera poprawkę podatności.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS