CVE-2025-14280
ŚrednieCVSS 5.3Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 35 - wyżej niż 35% wszystkich znanych CVE
Streszczenie
Wtyczka PixelYourSite dla WordPressa w wersjach do 11.1.5 włącznie jest podatna na ujawnienie wrażliwych informacji poprzez publicznie dostępne pliki logów. Nieuwierzytelniony atakujący może odczytać potencjalnie wrażliwe dane z logów, gdy włączone jest ustawienie "Meta API logs" (domyślnie wyłączone). Podatność została częściowo naprawiona w wersji 11.1.5, a w pełni w wersji 11.1.5.1.
Ocena ryzyka
Jeśli ustawienie logowania Meta API jest włączone, osoby postronne mogą uzyskać dostęp do wrażliwych danych zapisanych w logach bez logowania się do serwisu.
Rekomendacja
Zaktualizuj wtyczkę PixelYourSite do wersji 11.1.5.1 lub nowszej oraz upewnij się, że ustawienie "Meta API logs" jest wyłączone.
Inne podatności w PixelYourSite
Zobacz wszystkie- CVE-2026-109987Wysokie
Wtyczka WordPress PixelYourSite przed wersją 11.4.3 oraz PixelYourSite Pro przed wersją 12.6.8 nie sanityzują ani nie escapują wartości cookie przed wypisaniem jej do wyjścia strony. W witrynie korzystającej z pełnostronicowego cache pozwala to nieuwierzytelnionym atakującym zapisać ładunek Cross-Site Scripting w buforowanej stronie, która jest następnie serwowana innym odwiedzającym.
- CVE-2026-95530Średnie
W wtyczce PixelYourSite – Your smart PIXEL (TAG) Manager w wersjach do 11.4.1 występuje luka Cross Site Scripting (XSS) umożliwiająca atak przez użytkownika z rolą Subscriber. Atakujący z tą rolą może wstrzyknąć złośliwy skrypt.
- CVE-2026-18059Średnie
Wtyczka PixelYourSite dla WordPressa do wersji 11.2.1 ujawnia wrażliwe dane zakupów WooCommerce poprzez funkcję getWooPurchaseEventParams. Niezautoryzowani atakujący mogą wyodrębnić metadane zamówień, takie jak nazwy produktów, identyfikatory, ilości, ceny, sumy, walutę oraz identyfikatory zamówień, dla dowolnego istniejącego zamówienia, podając nieprawidłowy klucz zamówienia.
- CVE-2025-10588Średnie
Wtyczka PixelYourSite – Your smart PIXEL (TAG) & API Manager dla WordPress jest podatna na Cross-Site Request Forgery we wszystkich wersjach do 11.1.2 włącznie. Wynika to z braku lub nieprawidłowej walidacji nonce w funkcji adminEnableGdprAjax(). Umożliwia to nieuwierzytelnionym atakującym modyfikację ustawień RODO poprzez sfałszowane żądanie, jeśli uda im się nakłonić administratora witryny do wykonania czynności, takiej jak kliknięcie linku.
Oryginalny opis (angielski, źródło NVD)
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

