CVE-2022-1434
ŚrednieCVSS 5.9Prawdopodobieństwo exploitacji (EPSS)
Podwyższone ryzykoPercentyl 64 - wyżej niż 64% wszystkich znanych CVE
Streszczenie
Implementacja szyfru RC4-MD5 w OpenSSL 3.0 niepoprawnie używa danych AAD jako klucza MAC, co czyni ten klucz łatwym do przewidzenia. Atakujący w ataku man-in-the-middle może modyfikować przesyłane dane w taki sposób, że nadal przejdą one weryfikację integralności MAC. Problem dotyczy tylko OpenSSL 3.0.0–3.0.2 i został naprawiony w wersji 3.0.3.
Ocena ryzyka
Atakujący może zmodyfikować dane przesyłane między punktami końcowymi bez wykrycia przez mechanizm integralności, co może prowadzić do wstrzyknięcia lub zmiany treści komunikacji. Poufność danych nie jest naruszona — atakujący nie może odszyfrować danych, jedynie je modyfikować.
Rekomendacja
Zaktualizuj OpenSSL do wersji 3.0.3 lub nowszej. Jeśli to niemożliwe, upewnij się, że szyfrosuita RC4-MD5 nie jest dostępna (nie jest kompilowana z enable-weak-ssl-ciphers, legacy provider nie jest ładowany, nie jest dodana do listy szyfrów, a poziom bezpieczeństwa libssl wynosi co najmniej 1).
Inne podatności w OpenSSL
Zobacz wszystkie- CVE-2016-8610Wysokie
W OpenSSL 0.9.8, 1.0.1, 1.0.2 do 1.0.2h oraz 1.1.0 znaleziono lukę typu denial of service, która dotyczy przetwarzania pakietów ALERT podczas nawiązywania połączenia TLS/SSL. Zdalny atakujący może wykorzystać tę lukę, aby spowodować nadmierne zużycie CPU przez serwer TLS/SSL, co uniemożliwi akceptowanie połączeń od innych klientów.
- CVE-2017-3731Wysokie
Podatność CVE-2017-3731 dotyczy serwerów i klientów SSL/TLS działających na 32-bitowych hostach, które mogą ulegać awarii w wyniku odczytu poza granicami pamięci spowodowanego przez skrócony pakiet. W przypadku OpenSSL 1.1.0, awaria może być wywołana przy użyciu algorytmu CHACHA20/POLY1305, a w OpenSSL 1.0.2 przy użyciu RC4-MD5.
- CVE-2017-3730Wysokie
W OpenSSL w wersji 1.1.0 przed 1.1.0d, złośliwy serwer może dostarczyć nieprawidłowe parametry dla wymiany kluczy DHE lub ECDHE, co może prowadzić do próby dereferencji wskaźnika NULL przez klienta, skutkując awarią klienta.
- CVE-2016-7054Wysokie
W OpenSSL w wersji 1.1.0 przed 1.1.0c, połączenia TLS korzystające z szyfrów *-CHACHA20-POLY1305 są podatne na atak DoS poprzez uszkodzenie większych ładunków. Może to prowadzić do awarii OpenSSL.
- CVE-2016-7052Wysokie
W OpenSSL 1.0.2i występuje podatność, która pozwala zdalnym atakującym na spowodowanie awarii aplikacji poprzez wywołanie operacji CRL, co prowadzi do dereferencji wskaźnika NULL.
- CVE-2016-6305Wysokie
Funkcja ssl3_read_bytes w OpenSSL 1.1.0 przed wersją 1.1.0a pozwala zdalnym atakującym na wywołanie odmowy usługi (nieskończona pętla) poprzez wywołanie rekordu o zerowej długości w wywołaniu SSL_peek.
- CVE-2016-6304Wysokie
W OpenSSL przed wersją 1.0.1u, 1.0.2 przed 1.0.2i oraz 1.1.0 przed 1.1.0a występują wielokrotne wycieki pamięci w pliku t1_lib.c. Umożliwia to zdalnym atakującym spowodowanie odmowy usługi poprzez dużą ilość rozszerzeń żądania statusu OCSP.
- CVE-2016-6302Wysokie
Funkcja tls_decrypt_ticket w OpenSSL przed wersją 1.1.0 nie uwzględnia rozmiaru HMAC podczas walidacji długości biletu, co umożliwia zdalnym atakującym spowodowanie odmowy usługi za pomocą zbyt krótkiego biletu.
- CVE-2016-2179Wysokie
Implementacja DTLS w OpenSSL przed wersją 1.1.0 nie ogranicza prawidłowo czasu życia wpisów w kolejce związanych z nieużywanymi wiadomościami przychodzącymi w złej kolejności. To pozwala zdalnym atakującym na wywołanie odmowy usługi (zużycie pamięci) poprzez utrzymywanie wielu stworzonych sesji DTLS jednocześnie.
- CVE-2016-2176Wysokie
Funkcja X509_NAME_oneline w OpenSSL przed wersją 1.0.1t oraz 1.0.2 przed wersją 1.0.2h umożliwia zdalnym atakującym uzyskanie wrażliwych informacji z pamięci stosu procesu lub spowodowanie odmowy usługi (przepełnienie bufora) poprzez spreparowane dane EBCDIC ASN.1.
Oryginalny opis (angielski, źródło NVD)
The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly uses the AAD data as the MAC key. This makes the MAC key trivially predictable. An attacker could exploit this issue by performing a man-in-the-middle attack to modify data being sent from one endpoint to an OpenSSL 3.0 recipient such that the modified data would still pass the MAC integrity check. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL 3.0 endpoint will always be rejected by the recipient and the connection will fail at that point. Many application protocols require data to be sent from the client to the server first. Therefore, in such a case, only an OpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0 client. If both endpoints are OpenSSL 3.0 then the attacker could modify data being sent in both directions. In this case both clients and servers could be affected, regardless of the application protocol. Note that in the absence of an attacker this bug means that an OpenSSL 3.0 endpoint communicating with a non-OpenSSL 3.0 endpoint will fail to complete the handshake when using this ciphersuite. The confidentiality of data is not impacted by this issue, i.e. an attacker cannot decrypt data that has been encrypted using this ciphersuite - they can only modify it. In order for this attack to work both endpoints must legitimately negotiate the RC4-MD5 ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0, and is not available within the default provider or the default ciphersuite list. This ciphersuite will never be used if TLSv1.3 has been negotiated. In order for an OpenSSL 3.0 endpoint to use this ciphersuite the following must have occurred: 1) OpenSSL must have been compiled with the (non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL must have had the legacy provider explicitly loaded (either through application code or via configuration) 3) The ciphersuite must have been explicitly added to the ciphersuite list 4) The libssl security level must have been set to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must have been negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite in preference to any others that both endpoints have in common Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

