Katalog CVE

CVE-2021-21353

ŚrednieCVSS 6.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Bardzo wysokie ryzyko
4.27%

Percentyl 91 - wyżej niż 91% wszystkich znanych CVE

Streszczenie

Pug to silnik szablonów dla Node.js. W wersjach przed 3.0.1, jeśli atakujący zdalny mógł kontrolować opcję `pretty` kompilatora Pug (np. poprzez wstrzyknięcie obiektu użytkownika do danych wejściowych szablonu), możliwe było zdalne wykonanie kodu na backendzie Node.js. Podatność naprawiono w wersji 3.0.1, a dla pakietu pug-code-gen w wersji 2.0.3.

Ocena ryzyka

Podatność pozwala na zdalne wykonanie kodu, co może prowadzić do pełnego przejęcia serwera aplikacji. Ryzyko występuje tylko wtedy, gdy niezaufane dane wejściowe mogą trafić do opcji `pretty` kompilatora.

Rekomendacja

Zaktualizuj pakiet pug do wersji 3.0.1 lub nowszej, a pug-code-gen do 2.0.3. Upewnij się, że dane od użytkowników nie są przekazywane bezpośrednio do opcji kompilatora.

Inne podatności w Pug

Oryginalny opis (angielski, źródło NVD)

Pug is an npm package which is a high-performance template engine. In pug before version 3.0.1, if a remote attacker was able to control the `pretty` option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. This is fixed in version 3.0.1. This advisory applies to multiple pug packages including "pug", "pug-code-gen". pug-code-gen has a backported fix at version 2.0.3. This advisory is not exploitable if there is no way for un-trusted input to be passed to pug as the `pretty` option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS