CVE-2026-95530
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk10th percentile - higher than 10% of all known CVEs
Summary
Subscriber Cross Site Scripting (XSS) in PixelYourSite – Your smart PIXEL (TAG) Manager <= 11.4.1 versions.
Risk Assessment
A user with the Subscriber role can inject a malicious script that executes in other users' browsers, potentially leading to session theft or other attacks. The risk affects sites that allow user registration.
Recommendation
Update the PixelYourSite plugin to a version later than 11.4.1. Restrict content publishing capabilities for low-privileged users.
Other vulnerabilities in PixelYourSite
See all- CVE-2026-109987High
The PixelYourSite WordPress plugin before 11.4.3 and PixelYourSite Pro before 12.6.8 do not sanitise and escape a cookie value before printing it into the page output. On a site running a full-page cache, this allows unauthenticated attackers to store a Cross-Site Scripting payload in the cached page that is then served to other visitors.
- CVE-2026-18059Medium
The PixelYourSite plugin for WordPress up to version 11.2.1 exposes sensitive WooCommerce purchase metadata via the getWooPurchaseEventParams function. Unauthenticated attackers can extract order details such as product names, IDs, quantities, prices, totals, currency, and order IDs for any existing order by supplying an invalid order key.
- CVE-2025-14280Medium
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
- CVE-2025-10588Medium
The PixelYourSite – Your smart PIXEL (TAG) & API Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 11.1.2. This is due to missing or incorrect nonce validation on the adminEnableGdprAjax() function. This makes it possible for unauthenticated attackers to modify GDPR settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Original NVD description (English source)
Subscriber Cross Site Scripting (XSS) in PixelYourSite – Your smart PIXEL (TAG) Manager <= 11.4.1 versions.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

