CVE-2026-109987
HighCVSS 7.2Exploitation Probability (EPSS)
Low risk8th percentile - higher than 8% of all known CVEs
Summary
The PixelYourSite WordPress plugin before 11.4.3 and PixelYourSite Pro before 12.6.8 do not sanitise and escape a cookie value before printing it into the page output. On a site running a full-page cache, this allows unauthenticated attackers to store a Cross-Site Scripting payload in the cached page that is then served to other visitors.
Risk Assessment
A malicious script can be persisted in the cache and executed for all visitors, potentially leading to session or data theft. The risk applies to sites using full-page caching.
Recommendation
Update PixelYourSite to version 11.4.3 or later and PixelYourSite Pro to version 12.6.8 or later. After updating, purge the site cache.
Other vulnerabilities in PixelYourSite
See all- CVE-2026-95530Medium
Subscriber Cross Site Scripting (XSS) in PixelYourSite – Your smart PIXEL (TAG) Manager <= 11.4.1 versions.
- CVE-2026-18059Medium
The PixelYourSite plugin for WordPress up to version 11.2.1 exposes sensitive WooCommerce purchase metadata via the getWooPurchaseEventParams function. Unauthenticated attackers can extract order details such as product names, IDs, quantities, prices, totals, currency, and order IDs for any existing order by supplying an invalid order key.
- CVE-2025-14280Medium
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
- CVE-2025-10588Medium
The PixelYourSite – Your smart PIXEL (TAG) & API Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 11.1.2. This is due to missing or incorrect nonce validation on the adminEnableGdprAjax() function. This makes it possible for unauthenticated attackers to modify GDPR settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Original NVD description (English source)
The PixelYourSite WordPress plugin before 11.4.3, PixelYourSite Pro WordPress plugin before 12.6.8 do not sanitise and escape a cookie value before printing it into the page output, which, on a site running a full-page cache, allows unauthenticated attackers to store a Cross-Site Scripting payload in the cached page that is then served to other visitors.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

