CVE Catalog

CVE-2026-7012

LowCVSS 2.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

22th percentile - higher than 22% of all known CVEs

Summary

A vulnerability was detected in MaxSite CMS up to 109.3 in the Redirect Plugin. Manipulation of the f_all/f_all404 arguments leads to cross-site scripting (XSS), and the attack can be launched remotely. The exploit is publicly available, and the vendor classifies it as Self-XSS and fixed it in version 109.4.

Risk Assessment

XSS can allow execution of malicious scripts in a user's browser, potentially leading to session or data theft. Since the exploit is public, the risk of exploitation increases.

Recommendation

Upgrade MaxSite CMS to version 109.4 or later, which contains the security fix. Avoid clicking unknown links and validate input data.

Other vulnerabilities in MaxSite CMS

See all
Original NVD description (English source)

A vulnerability was detected in MaxSite CMS up to 109.3. This affects an unknown part of the component Redirect Plugin. The manipulation of the argument f_all/f_all404 results in cross site scripting. The attack can be launched remotely. The exploit is now public and may be used. Upgrading to version 109.4 is able to mitigate this issue. The patch is identified as 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. You should upgrade the affected component. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."

Vulnerability data from NVD (NIST) · CISA KEV · EPSS