CVE-2026-7011
LowCVSS 2.4Exploitation Probability (EPSS)
Low risk19th percentile - higher than 19% of all known CVEs
Summary
A weakness was identified in MaxSite CMS up to 109.3 in an unknown functionality of the /admin/plugin_antispam file of the Antispam Plugin. Manipulation of the f_logging_file argument can lead to cross-site scripting (XSS), and the attack can be launched remotely. The exploit is publicly available, and the vendor classifies it as Self-XSS and fixed it in version 109.4.
Risk Assessment
XSS can allow execution of malicious scripts in a user's browser, potentially leading to session or data theft. Since the exploit is public, the risk of exploitation increases.
Recommendation
Upgrade MaxSite CMS to version 109.4 or later, which contains the security fix. Avoid clicking unknown links and validate input data.
Other vulnerabilities in MaxSite CMS
See all- CVE-2026-87929Critical
MaxSite CMS through 109.6 ships with a hardcoded session encryption key in application/config/config.php that is never changed during installation, allowing unauthenticated attackers to forge administrator session cookies. Attackers can mint a malicious ci_session cookie with administrator privileges by computing an HMAC-SHA1 using the publicly known encryption key, bypassing authentication checks in is_login() and mso_check_allow() functions.
- CVE-2026-70554Critical
MaxSite CMS contains a PHP object injection vulnerability that allows unauthenticated attackers to execute arbitrary code by passing attacker-controlled serialized data in the maxsite_comuser cookie directly to unserialize() without validation. Attackers can use gadget chains such as SoapClient or Imagick for remote code execution.
- CVE-2026-70553Critical
MaxSite CMS contains a remote code execution vulnerability that allows unauthenticated attackers to inject arbitrary PHP code into the application configuration file by submitting crafted POST requests to the install endpoint after installation. Attackers can exploit the db_dbprefix value to break out of a PHP string literal and add their own code.
- CVE-2026-70552Critical
MaxSite CMS 109.5 and earlier contain an authentication bypass vulnerability in the AJAX dispatcher that allows unauthenticated attackers to access admin-gated endpoints by supplying any X-Requested-With header and requesting a base64-encoded path to any *-ajax.php file. This can enable manipulation of poll states and vote counts.
- CVE-2026-87930High
MaxSite CMS through 109.6 passes the ci_session cookie to unserialize() without class restrictions, allowing unauthenticated attackers to inject PHP objects. Attackers can forge valid session cookies using the hardcoded encryption key to trigger magic methods and corrupt application state or achieve code execution if gadget classes exist.
- CVE-2026-87928Medium
MaxSite CMS versions 0.94 through 109.6 contain a cross-site scripting vulnerability in the admin_page upload handler that allows any logged-in user to upload HTML files. Attackers can upload HTML containing malicious scripts to the uploads/_pages/ directory, which executes in visitors' browsers when accessed, enabling persistent stored XSS attacks.
- CVE-2026-87927High
MaxSite CMS through 109.6 contains a local file inclusion vulnerability in the ajax and require-maxsite dispatchers that allows unauthenticated attackers to execute privileged handler files by supplying base64-encoded path traversal sequences. Attackers can bypass path validation checks and execute admin-gated handler actions without authentication to access sensitive functionality.
- CVE-2026-37700Medium
Cross-Site Scripting vulnerability in MaxSite CMS v.109.2 allows a remote attacker to obtain sensitive information via the Backend page file upload endpoint used by admin_page.
- CVE-2026-7016Low
A vulnerability was found in MaxSite CMS up to 109.3. An unknown function of the ushki Plugin component is impacted. Manipulation of the f_ushka_new/f_ushk argument results in cross site scripting, remote exploitation is possible, and the exploit has been made public. The vendor classifies it as "Self-XSS" and recommends upgrading to 109.4.
- CVE-2026-7015Low
A vulnerability has been found in MaxSite CMS up to 109.3. Some unknown processing of the Guestbook Plugin component is affected. Manipulation of the f_text/f_slug/f_limit/f_email argument leads to cross site scripting, the attack may be launched remotely, and the exploit has been disclosed publicly. The vendor classifies it as "Self-XSS" and recommends upgrading to 109.4.
Original NVD description (English source)
A weakness has been identified in MaxSite CMS up to 109.3. Affected by this vulnerability is an unknown functionality of the file /admin/plugin_antispam of the component Antispam Plugin. Executing a manipulation of the argument f_logging_file can lead to cross site scripting. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 109.4 addresses this issue. This patch is called 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. Upgrading the affected component is advised. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

