CVE Catalog

CVE-2026-6646

MediumCVSS 6.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.28%

20th percentile - higher than 20% of all known CVEs

Summary

The The7 theme for WordPress up to and including 14.3.2 is vulnerable to stored cross-site scripting via the 'dt_default_button' shortcode. This is due to insufficient input sanitization and output escaping on the 'title' component of the 'link' shortcode parameter. Authenticated attackers with Contributor-level access or above can inject arbitrary web scripts.

Risk Assessment

An attacker with Contributor privileges can inject malicious scripts that execute for users visiting the page, potentially leading to session theft or account takeover.

Recommendation

Upgrade the The7 theme to a version later than 14.3.2 that fixes this vulnerability. Until then, restrict Contributor privileges.

Related vulnerabilities

Original NVD description (English source)

The The7 theme for WordPress is vulnerable to Stored Cross-Site Scripting via the 'dt_default_button' shortcode in all versions up to, and including, 14.3.2. This is due to insufficient input sanitization and output escaping on the 'title' component of the 'link' shortcode parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS