CVE Catalog

CVE-2026-33888

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.51%

43th percentile - higher than 43% of all known CVEs

Summary

ApostropheCMS versions 4.28.0 and prior contain an authorization bypass in the getRestQuery method of the @apostrophecms/piece-type module. An unauthenticated attacker can supply a project query parameter in a REST API request, causing publicApiProjection to be skipped and disclosing fields the administrator restricted from the public API, such as internal notes, draft content, or metadata.

Risk Assessment

This can lead to leakage of sensitive data from publicly queryable documents without authentication.

Recommendation

Update ApostropheCMS to version 4.29.0 or later.

Other vulnerabilities in ApostropheCMS

See all
Original NVD description (English source)

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the getRestQuery method of the @apostrophecms/piece-type module, where the method checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request, which is processed by applyBuildersSafely before the permission check, pre-populating the projection state and causing the publicApiProjection to be skipped entirely. This allows disclosure of any field on publicly queryable documents that the administrator explicitly restricted from the public API, such as internal notes, draft content, or metadata. Exploitation is trivial, requiring only appending query parameters to a public URL with no authentication. This issue has been fixed in version 4.29.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS