CVE Catalog

CVE-2026-26929

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.42%

37th percentile - higher than 37% of all known CVEs

Summary

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned.

Risk Assessment

This may disclose version and existence information of DAGs to unauthorized users, violating access control.

Recommendation

Upgrade Apache Airflow to version 3.1.8 or later.

Other vulnerabilities in Apache Airflow

See all
Original NVD description (English source)

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS