Actively exploited in the wild
Ahsay AhsayCBS Command Injection Vulnerability
Ahsay - AhsayCBS · Listed in the CISA KEV since 2026-10-14. This indicates confirmed attacks in production environments.
Required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
CVE-2026-105134
CriticalCVSS 10.0KEVExploitation Probability (EPSS)
Very high risk100th percentile - higher than 100% of all known CVEs
Summary
A flaw was found in AhsayCBS up to 9.15.2.69/10.3.4.44 affecting the Replication Receiver component in /rps/api/json/UpdateReceivers.do. Manipulating the 'random' argument can lead to OS command injection, and the attack can be launched remotely. The exploit has been published and may be used.
Risk Assessment
A remote attacker can execute arbitrary OS commands on the backup server, leading to full system compromise and data confidentiality loss. The public exploit increases the likelihood of rapid exploitation.
Recommendation
Immediately upgrade AhsayCBS to version 9.15.2.70 or 10.3.4.45, as the initial patch did not properly fix the vulnerability. Until patched, restrict access to the API interface.
Other vulnerabilities in AhsayCBS
Original NVD description (English source)
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

