CVE Catalog

CVE-2025-9198

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.34%

26th percentile - higher than 26% of all known CVEs

Summary

The Wp cycle text announcement plugin for WordPress, up to version 8.1, is vulnerable to SQL Injection via the 'cycle-text' shortcode. Insufficient escaping and lack of query preparation allow authenticated attackers with Contributor-level access and above to append additional SQL queries, potentially extracting sensitive information from the database.

Risk Assessment

An authenticated attacker with Contributor privileges can access sensitive data in the database, such as passwords, user data, or other confidential information, potentially leading to a full system compromise.

Recommendation

Update the plugin to a version newer than 8.1 that includes a fix for the SQL Injection vulnerability.

Related vulnerabilities

Original NVD description (English source)

The Wp cycle text announcement plugin for WordPress is vulnerable to SQL Injection via the 'cycle-text' shortcode in all versions up to, and including, 8.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS