CVE Catalog

CVE-2025-66030

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.32%

23th percentile - higher than 23% of all known CVEs

Summary

An integer overflow vulnerability in node-forge versions 1.3.1 and below allows remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. Due to 32-bit bitwise truncation, these arcs may be decoded as smaller, trusted OIDs, enabling bypass of downstream OID-based security decisions. The issue is patched in version 1.3.2.

Risk Assessment

A remote, unauthenticated attacker may bypass OID-based security mechanisms (e.g., certificate or policy validation), potentially leading to unauthorized access or acceptance of unsafe structures.

Recommendation

Update node-forge to version 1.3.2 or later across all applications and dependencies. Verify that applications using this library do not rely solely on OID-based security decisions.

Other vulnerabilities in node-forge

See all
Original NVD description (English source)

Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Integer Overflow vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions. This issue has been patched in version 1.3.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS