CVE Catalog

CVE-2026-118779

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.56%

46th percentile - higher than 46% of all known CVEs

Summary

In node-forge before 1.4.1, pem.decode() in lib/pem.js used polynomial-time regular expressions, including when searching for a matching END line and parsing encapsulated headers. An unauthenticated attacker able to supply PEM input to any high-level parser could consume excessive CPU with a long malformed message and cause denial of service.

Risk Assessment

An attacker can send a long malformed PEM message to block the Node.js process and prevent handling of other requests. This results in denial of service for applications processing untrusted PEM data.

Recommendation

Update node-forge to version 1.4.1 or later. Limit the size and complexity of PEM data accepted from users and consider processing time limits.

Other vulnerabilities in node-forge

See all
Original NVD description (English source)

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, the affected implementation used pem.decode(), lib/pem.js, missing END line to process the relevant input or security decision. node-forge used polynomial-time regular expressions in pem.decode(), including when searching for a matching END line and parsing encapsulated headers. An unauthenticated attacker able to supply PEM input to any high-level parser could consume excessive CPU with a long malformed message and cause denial of service. This issue is fixed in version 1.4.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS