CVE Catalog

CVE-2025-61915

MediumCVSS 6.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.46%

38th percentile - higher than 38% of all known CVEs

Summary

In OpenPrinting CUPS before version 2.4.15, a user in the lpadmin group can use the web UI to change the config and insert a malicious line. The cupsd process running as root parses the new config, causing an out-of-bounds write.

Risk Assessment

The risk includes privilege escalation and potential system compromise by a user in the lpadmin group, possibly leading to full takeover.

Recommendation

Upgrade CUPS to version 2.4.15 or later, which includes a fix for this vulnerability.

Other vulnerabilities in OpenPrinting CUPS

See all
Original NVD description (English source)

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS