CVE Catalog

CVE-2025-54057

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.76%

54th percentile - higher than 54% of all known CVEs

Summary

Apache SkyWalking contains a Basic XSS vulnerability due to improper neutralization of script-related HTML tags in web pages. The issue affects versions up to and including 10.2.0.

Risk Assessment

An attacker could inject malicious script that executes in the application user's browser, potentially leading to session or data theft.

Recommendation

Upgrade Apache SkyWalking to version 10.3.0, which fixes the issue.

Other vulnerabilities in Apache SkyWalking

Original NVD description (English source)

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS