CVE Catalog

CVE-2006-3747

High
Published: Translated: NVD NIST

Summary

Off-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled. A remote attacker can cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.

Risk Assessment

The vulnerability can lead to denial of service (web server crash) and potentially remote code execution, which could result in full server compromise. This affects organizations using vulnerable Apache versions with mod_rewrite enabled and rewrite rules based on the ldap scheme.

Recommendation

Update Apache to version 2.0.59 or later (or the appropriate patched version for the 1.3/2.2 branches) as soon as possible. If immediate update is not feasible, consider disabling mod_rewrite or restricting rules that use the ldap scheme.

Related vulnerabilities

Original NVD description (English source)

Off-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS