CVE-2026-97868
LowCVSS 3.5Exploitation Probability (EPSS)
Low risk8th percentile - higher than 8% of all known CVEs
Summary
A security vulnerability has been detected in sheshbabu zen up to 1.5.0. The function dangerouslySetInnerHTML in the Note Editor component is affected, leading to cross-site scripting. The attack can be initiated remotely, and the exploit has been publicly disclosed.
Risk Assessment
The risk is remote execution of malicious scripts in the user's browser, potentially leading to data theft, session hijacking, or other attacks.
Recommendation
Upgrade to a version above 1.5.0 or apply security patches if available.
Related vulnerabilities
- CVE-2026-95860Critical
In node-opcua (an OPC UA implementation for TypeScript and Node.js), versions 2.42.0 through 2.180.0 do not honor namespace-level access control configured via setDefaultRolePermissions for nodes without explicit per-node permissions. SessionContext.getApplicableRolePermissions reads a missing or null value instead of the configured namespace field, and the null result is treated permissively. As a result, an anonymous network client can write variables or call bound methods when an operator relied on restrictive namespace defaults.
- CVE-2026-82158Critical
Dell Wyse Management Suite versions prior to 2609.0.0.155 contain a cross-site scripting vulnerability (improper neutralization of input during web page generation). A low-privileged attacker with remote access could exploit it to inject script.
- CVE-2026-115732Critical
Incorrect authorization in certificate-name matching in trapperkeeper-authorization, as used by Puppet Server, allows a client holding a CA-signed certificate whose name extends or shortens an authorized hostname to be authorized as that host. This enables impersonation of other nodes and, in Puppet Enterprise, access to certificate-authority administration and remote command execution on managed nodes.
- CVE-2026-115731Critical
Deserialization of untrusted data in Puppet's report-processing code, as used by Puppet Server, allows a client holding any CA-signed agent certificate to execute arbitrary code on the Puppet Server as its service user by submitting a report with a crafted rich-data type via a PUT request. Where the CA autosigns requests without strong verification, an unauthenticated network attacker can obtain such a certificate.
- CVE-2026-95733Critical
A vulnerability exists in a component of HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to execute arbitrary code on the affected system.
- CVE-2026-95732Critical
An authentication bypass vulnerability exists in the underlying operating system of HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to execute arbitrary code on the affected system.
- CVE-2026-95731Critical
Hardcoded password vulnerabilities in the command-line interface of HPE Networking Fabric Composer could allow an unauthenticated remote attacker to access the affected system using hardcoded credentials. Successful exploitation could grant unauthorized administrative access with elevated privileges.
- CVE-2026-63471Critical
Prior to 0.8.1, fastapi-code-generator inserts an OpenAPI path into a generated @app.get(...) route decorator as a single-quoted string without escaping embedded quotes. An attacker-influenced OpenAPI path can close the string and inject a valid Python expression into the decorator argument. Syntactically valid generated code executes with the application's or CI process's privileges when the module is imported.
- CVE-2026-63470Critical
Prior to 0.8.1, fastapi-code-generator inserts Operation.summary into a generated route-handler docstring as a triple-double-quoted string without escaping embedded triple quotes. An attacker-influenced operation summary can close the docstring and inject a valid Python expression statement into the handler body. Syntactically valid generated code executes with the server process's privileges when the affected route handler is called.
- CVE-2026-63469Critical
Prior to 0.8.1, fastapi-code-generator inserts an additional response status-code key into the generated responses={...} route-decorator dictionary as a single-quoted Python string without escaping embedded quotes. An attacker-influenced second non-primary response key can close the dictionary-key literal and inject a valid Python expression. Syntactically valid generated code executes with the application's or CI process's privileges when the module is imported.
Original NVD description (English source)
A security vulnerability has been detected in sheshbabu zen up to 1.5.0. Affected by this issue is the function dangerouslySetInnerHTML of the file features/notes/NotesEditor.jsx of the component Note Editor. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

