CVE Catalog

CVE-2026-97019

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.24%

15th percentile - higher than 15% of all known CVEs

Summary

The AMP for WP – Accelerated Mobile Pages plugin for WordPress up to and including 1.1.17 is vulnerable to stored cross-site scripting via the 'headline-*' shortcode attribute due to insufficient input sanitization and output escaping. A Subscriber-level user can store a malicious shortcode in their biographical info field that executes when a user accesses the page.

Risk Assessment

An attacker can inject arbitrary scripts that execute in the browsers of users visiting the infected page, potentially leading to session or data theft. The risk affects both administrators and visitors.

Recommendation

Update the plugin to a version later than 1.1.17. Consider restricting profile editing for low-privilege users until the update is applied.

Other vulnerabilities in AMP for WP – Accelerated Mobile Pages

Original NVD description (English source)

The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'headline-*' Shortcode Attribute in all versions up to, and including, 1.1.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A Subscriber-level user can store a malicious shortcode in their biographical info field; because WordPress core's wp_filter_kses() only strips HTML tags and not shortcode syntax, and because AMP content sanitizers run before do_shortcode() processes the archive description, the synthesized markup is never post-sanitized.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS