CVE-2026-93342
MediumCVSS 5.4Exploitation Probability (EPSS)
Low risk25th percentile - higher than 25% of all known CVEs
Summary
The MarketKing plugin for WordPress before 2.1.72 contains a missing authorization vulnerability in the marketking_duplicate_product AJAX action that allows authenticated attackers with subscriber-level access or higher to duplicate any vendor's product by supplying an arbitrary product ID. Attackers can bypass ownership verification, copy any vendor's product listings including private metadata, and assign the duplicate to their own account without the victim's consent.
Risk Assessment
Product and metadata theft can lead to data integrity issues and competitive harm. It may also enable content theft or manipulation of listings.
Recommendation
Update the MarketKing plugin to version 2.1.72 or later. Also monitor product duplication activities and strengthen access controls.
Other vulnerabilities in MarketKing
See all- CVE-2026-111847Medium
The MarketKing plugin for WooCommerce contains a missing authorization vulnerability, allowing exploitation of incorrectly configured access control security levels. This issue affects MarketKing versions up to and including 2.1.72.
- CVE-2026-94080Medium
Broken Access Control vulnerability in the MarketKing plugin in versions up to and including 2.1.70. The vulnerability can be exploited by an unauthenticated attacker.
- CVE-2026-93344Medium
MarketKing plugin for WordPress before 2.1.72 contains a missing authorization vulnerability in the marketking_get_page_content AJAX action that allows authenticated attackers with subscriber-level access or higher to access arbitrary vendor administrator panel pages by supplying an arbitrary vendor user ID. Attackers can bypass authorization controls by submitting a target vendor ID in the request to access payout pages, financial reports, and vendor dashboard content belonging to any vendor in the marketplace.
- CVE-2026-93343Medium
The MarketKing plugin for WordPress before 2.1.72 contains a missing authorization vulnerability in the marketking_admin_vendors_ajax AJAX action that allows authenticated attackers with subscriber-level access or higher to retrieve the complete vendor directory. By sending a crafted AJAX request, they can obtain internal user IDs, usernames, and email addresses of all registered vendors, exposing personally identifiable information.
- CVE-2026-93341Medium
The MarketKing plugin for WordPress before 2.1.72 contains a missing authorization vulnerability in the marketking_send_refund AJAX action that allows authenticated attackers with subscriber-level access or higher to create refund requests against any order by supplying an arbitrary order ID. Attackers can submit crafted AJAX requests to create fraudulent refund requests against orders they did not place, causing marketplace disruption and unauthorized interference.
- CVE-2026-85311Medium
Missing Authorization vulnerability in MarketKing by Kings Plugins allows exploiting incorrectly configured access control security levels. Affects versions through 2.1.60.
- CVE-2026-27399Medium
The MarketKing plugin for WordPress versions 2.1.40 and earlier contains a broken access control vulnerability exploitable by an unauthenticated attacker.
- CVE-2025-58702Medium
The WordPress plugin MarketKing (marketking-multivendor-marketplace-for-woocommerce) up to version 2.0.92 is vulnerable to stored XSS due to improper input neutralization during page generation. An attacker can inject malicious code that gets stored and executed in the user's browser.
Original NVD description (English source)
MarketKing plugin for WordPress before 2.1.72 contains a missing authorization vulnerability in the marketking_duplicate_product AJAX action that allows authenticated attackers with subscriber-level access or higher to duplicate any vendor's product by supplying an arbitrary product ID. Attackers can bypass ownership verification to copy any vendor's product listings, including private product metadata, and assign the duplicated copy to their own vendor account without the victim's knowledge or consent.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

