CVE-2026-92415
MediumCVSS 5.3Exploitation Probability (EPSS)
Low risk26th percentile - higher than 26% of all known CVEs
Summary
A vulnerability of type "Use of Externally-Controlled Input to Select Classes or Code" in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH).
Risk Assessment
The risk is that a malicious server or man-in-the-middle attacker can execute arbitrary code or manipulate files, leading to system and data integrity compromise.
Recommendation
Upgrade Apache Jackrabbit to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue. Also secure network connections against interception.
Other vulnerabilities in Apache Jackrabbit
See all- CVE-2016-6801High
CVE-2016-6801 involves a content-type check vulnerability in Jackrabbit-Webdav, allowing remote attackers to hijack the authentication of victims for resource creation via an HTTP POST request with a missing or crafted Content-Type header.
- CVE-2026-92414Critical
Session Fixation / Session Reuse vulnerability in Apache Jackrabbit. The WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match without credential check. Affects versions from 2.23.0 through 2.23.5, 2.22.0 through 2.22.4, and 2.20.0 through 2.20.17.
- CVE-2025-58782Medium
Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons (versions 1.0.0 through 2.22.1). Deployments that accept JNDI URIs for JCR lookup from untrusted users allow them to inject malicious JNDI references, potentially leading to arbitrary code execution.
Original NVD description (English source)
— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

