CVE-2026-92086
MediumCVSS 5.3Summary
The MW WP Form plugin for WordPress up to and including 5.1.7 is vulnerable to Sensitive Information Exposure via the 'post_id' parameter. Unauthenticated attackers can extract personally identifiable information from other users' form inquiry records, including names, email addresses and message bodies, by enumerating sequential post IDs.
Risk Assessment
Exposure of personal data (names, emails, message contents) may violate GDPR and erode user trust. Exploitation requires the querystring setting to be enabled on the target form, which is a standard documented plugin feature.
Recommendation
Update MW WP Form to a version later than 5.1.7 and consider disabling the querystring setting on forms where it is not required.
Other vulnerabilities in MW WP Form
See all- CVE-2026-96567High
The MW WP Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_id' parameter in all versions up to and including 5.1.7 due to insufficient input sanitization and output escaping. The CSRF gate protecting form submission is bypassable by any unauthenticated visitor who first loads the public form page to obtain a valid double-submit cookie.
- CVE-2026-78363Medium
The MW WP Form WordPress plugin before 5.1.5 does not prevent shortcodes in user-submitted values from being executed when it merges those values into a message that it later processes for shortcodes, allowing unauthenticated users to run any shortcode registered on the site. Exploitation requires the site to have been configured to echo a submitted value back to the visitor after submission.
- CVE-2026-78364Low
The MW WP Form WordPress plugin before 5.1.6 does not sanitise and escape some of its form settings before outputting them back in an admin dashboard page, which could allow users with a role as low as Editor to perform Stored Cross-Site Scripting attacks against high privilege users such as admin.
- CVE-2026-48871High
Versions of MW WP Form <= 5.1.3 are vulnerable to unauthenticated Cross Site Scripting (XSS). An attacker can exploit this vulnerability to inject malicious JavaScript code.
- CVE-2026-5436High
Vulnerability in the MW WP Form plugin for WordPress up to version 5.1.1. Insufficient validation of the $name parameter allows an unauthenticated attacker to move arbitrary files on the server, potentially leading to remote code execution.
Original NVD description (English source)
The MW WP Form plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.1.7 via the 'post_id' parameter. This makes it possible for unauthenticated attackers to extract personally identifiable information from other users' form inquiry records, including submitted names, email addresses, and free-text message bodies, by enumerating sequential post IDs. Exploitation requires the targeted form to have the querystring setting enabled, but this is a standard documented feature of the plugin.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

