CVE Catalog

CVE-2026-90932

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.82%

57th percentile - higher than 57% of all known CVEs

Summary

LaraDashboard versions 0.9.2 through 1.2.2 contain a path traversal vulnerability in core-upgrade backup handling. CoreUpgradeController and BackupService concatenate the user-supplied backup_file/filename value directly onto the backup directory path without normalisation, without basename(), and without verifying that the resolved path remains inside storage/app/core-backups; an authenticated user holding only the delegated settings.edit permission can supply ../ traversal sequences to delete arbitrary files or restore a ZIP archive from an arbitrary on-disk location, writing arbitrary files into application directories and achieving remote code execution.

Risk Assessment

An authenticated user with limited permissions can delete arbitrary files or execute arbitrary code, leading to serious application and host compromise.

Recommendation

Update LaraDashboard to version 1.3.0 or later and restrict the settings.edit permission to trusted users.

Other vulnerabilities in LaraDashboard

See all
Original NVD description (English source)

LaraDashboard versions 0.9.2 through 1.2.2 contain a path traversal vulnerability in the core-upgrade backup handling. CoreUpgradeController and BackupService (e.g. BackupService::deleteBackup()) concatenate the user-supplied backup_file/filename value directly onto the backup directory path without normalisation, without applying basename(), and without verifying that the resolved path remains inside storage/app/core-backups; the corresponding form requests only validate the value as a bounded string. An authenticated user holding only the delegated settings.edit permission (not Superadmin) can supply ../ traversal sequences to delete arbitrary files reachable on the host filesystem, including outside the application tree, or to restore a ZIP archive from an arbitrary on-disk location, writing arbitrary files into the application directories and achieving remote code execution. Note: the advisory states the vulnerable concatenation was introduced in the v0.9.7 release line. Fixed in 1.3.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS