CVE-2026-86341
MediumCVSS 4.4Exploitation Probability (EPSS)
Low risk22th percentile - higher than 22% of all known CVEs
Summary
GitLab has remediated an issue in GitLab EE affecting all versions from 17.1 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions, an authenticated user with Owner or Maintainer permissions could have silently disabled protected environment deployment approval requirements, allowing unapproved deployments to reach production, due to improper access control checks performed after the protected resource was modified.
Risk Assessment
The risk is the possibility of unauthorized deployments to production, potentially leading to the introduction of untested changes and potential outages.
Recommendation
It is recommended to upgrade GitLab EE to version 19.1.8, 19.2.6, or 19.3.2 or later, and to review protected environment configurations.
Other vulnerabilities in GitLab EE
See all- CVE-2026-7481High
GitLab has remediated an issue in GitLab EE affecting all versions from 16.4 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3. This issue could have allowed an authenticated user with developer-role permissions to execute arbitrary JavaScript in other users' browsers due to improper input sanitization.
- CVE-2026-7377High
GitLab has remediated an issue in GitLab EE affecting all versions from 18.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3. In customizable analytics dashboards, an authenticated user could have executed arbitrary JavaScript in the context of other users' browsers due to improper input sanitization.
- CVE-2026-6073High
GitLab has remediated an issue in GitLab EE affecting all versions from 18.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3. This issue could have allowed an authenticated user to execute arbitrary JavaScript in other users' browsers due to improper input sanitization.
- CVE-2026-14288Low
GitLab has remediated an issue in GitLab EE affecting versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could allow an authenticated user to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.
- CVE-2026-112378Medium
GitLab EE in versions from 17.8 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 contains an issue that under certain conditions could allow an authenticated user to access paid AI features without a valid subscription due to insufficient server-side validation in billing eligibility checks.
- CVE-2026-112326Low
GitLab EE contains a cleanup logic flaw that fails to distinguish pre-existing vulnerability records from newly created ones during error handling. Under certain conditions, an authenticated user with read-only permissions could permanently delete existing vulnerability records. This issue affects versions from 17.8 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1.
- CVE-2026-103515Low
GitLab has remediated an issue in GitLab EE affecting versions from 19.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 where, when an instance administrator locked a group's Duo availability, an authenticated user with group Owner permissions could re-enable AI-backed data egress to a third-party service for that group and its descendant projects, due to insufficient granularity of the admin-lock enforcement controls.
- CVE-2026-9268Low
GitLab EE versions from 13.6 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 have a vulnerability that, under certain conditions, could allow an authenticated user with limited permissions to modify CI/CD deployment rollback settings without authorization, due to insufficient access control checks.
- CVE-2026-96893High
A vulnerability in GitLab EE could, under certain conditions, allow an authenticated user to inject specially crafted content into AI agent instructions, potentially causing unintended command execution attributed to other users. Affects versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2.
- CVE-2026-92528Medium
GitLab EE versions from 16.11 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 have a fixed issue that, under certain conditions, could allow an authenticated user to approve a merge request despite having contributed commits to it, due to improper identity resolution.
Original NVD description (English source)
GitLab has remediated an issue in GitLab EE affecting all versions from 17.1 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions, an authenticated user with Owner or Maintainer permissions could have silently disabled protected environment deployment approval requirements, allowing unapproved deployments to reach production, due to improper access control checks performed after the protected resource was modified.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

