CVE-2026-82639
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk22th percentile - higher than 22% of all known CVEs
Summary
NextChat versions from 2.15.8 through 2.16.1 contain an improper URL validation vulnerability in the proxy endpoint that allows attackers to obtain the server's OpenAI API key. The x-base-url header is validated using substring matching instead of hostname parsing, allowing any URL containing 'api.openai.com' to pass validation and receive the server's credentials in the Authorization header.
Risk Assessment
Risk of exposing the OpenAI API key, potentially leading to unauthorized resource usage and financial costs.
Recommendation
Update NextChat to a version newer than 2.16.1 that fixes this vulnerability. Additionally, consider restricting access to the proxy endpoint.
Other vulnerabilities in NextChat
See all- CVE-2026-118132Low risk· EPSS 13%
NextChat version 2.16.1 contains a client-side cross-site scripting (XSS) vulnerability in the Plugin Editor due to unsafe rendering of externally supplied OpenAPI plugin schema content. Content loaded from a remote URL is stored in plugin.content and rendered via React's dangerouslySetInnerHTML without proper sanitization, allowing arbitrary JavaScript execution in the NextChat origin.
- CVE-2026-105238High
A flaw has been found in ChatGPTNextWeb NextChat up to 2.16.1. This vulnerability affects the function proxyHandler of the file app/api/proxy.ts of the component Proxy Fallback Handler. This manipulation of the argument x-base-url causes server-side request forgery. It is possible to initiate the attack remotely. The exploit has been published and may be used. The pull request to fix this issue awaits acceptance.
- CVE-2026-7643Medium
A flaw was found in ChatGPTNextWeb NextChat up to 2.16.1 affecting an unknown function of the Next.js file in the API Endpoint component. Manipulation can lead to a permissive cross-domain policy with untrusted domains, and the attack may be launched remotely.
Original NVD description (English source)
NextChat versions from 2.15.8 through 2.16.1 contain an improper URL validation vulnerability in the proxy endpoint that allows attackers to obtain the server's OpenAI API key. The x-base-url header is validated using substring matching instead of hostname parsing, allowing any URL containing 'api.openai.com' to pass validation and receive the server's credentials in the Authorization header.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

