CVE Catalog

CVE-2026-80312

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.51%

43th percentile - higher than 43% of all known CVEs

Summary

A vulnerability in the Apache Camel OAuth component causes camel-oauth processors guarding a route to not stop the exchange when authentication cannot be completed. As a result, an unauthenticated caller can reach the protected endpoint as though authentication had succeeded (fail-open). This affects Apache Camel from 4.11.0 before 4.18.5 and from 4.19.0 before 4.22.1.

Risk Assessment

The organization may be exposed to unauthorized access to protected resources because an authentication failure does not terminate the request. An attacker can exploit the ordinary request path without special configuration or prior access.

Recommendation

Upgrade Apache Camel to 4.23.0, or to 4.18.5 or 4.22.1 for the respective LTS streams. If immediate upgrade is not possible, add an explicit authorization check after the OAuth processor and verify that the route stops on failure.

Other vulnerabilities in Apache Camel

See all
Original NVD description (English source)

Improper Authentication vulnerability in Apache Camel OAuth component. This issue affects Apache Camel: from 4.11.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-oauth processors that guard a route did not stop the exchange when authentication could not be completed. Where a failure to establish an authenticated session should have terminated routing and returned an error to the caller, the processors fell through and returned control to the route, so the request continued to the protected endpoint as though authentication had succeeded. The effect is a fail-open authentication guard: an unauthenticated caller reached whatever the route did next. The condition is reached on the ordinary request path of a route configured to require OAuth, and needs no special configuration or prior access on the caller's part. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The processors now stop the exchange and set the appropriate error status whenever an authenticated session cannot be established, so a failed authentication no longer reaches the protected part of the route. For deployments that cannot upgrade immediately, place an explicit authorization check after the OAuth processor rather than relying on it to halt the exchange, and verify that the route stops on failure.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS