CVE Catalog

CVE-2026-75857

HighCVSS 7.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.16%

5th percentile - higher than 5% of all known CVEs

Summary

The exec_shell_interact (alias exec_interact) tool in CodeWhale returns ApprovalRequirement::Auto, overriding the default Required approval for code-executing tools. As a result, LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., python3 -i, mysql, ssh, sudo -i) without any approval prompt.

Risk Assessment

An attacker can inject instructions via untrusted content the agent ingests (fetched pages, MCP results, repo files) and run commands at the privilege level of the approved process. This may lead to arbitrary code execution in a higher-privileged context.

Recommendation

Update codewhale / codewhale-tui to version 0.8.64 or later. The deprecated deepseek-tui crate has no fixed release and should no longer be used.

Other vulnerabilities in CodeWhale

See all
Original NVD description (English source)

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS