CVE Catalog

CVE-2026-75520

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.28%

20th percentile - higher than 20% of all known CVEs

Summary

In Domoticz prior to 2026.3, the udevices JSON command handler (Cmd_UpdateDevices in main/WebServerCmds.cpp) performed no session.rights check before invoking a Lua parser script. A low-privilege authenticated user could trigger execution of an existing operator-installed Lua parser script with attacker-controlled input via GET /json.htm, and the script parameter lacked a path-traversal guard. Execution is limited to already-installed valid Lua files, and the issue is addressed in version 2026.3.

Risk Assessment

A low-privilege authenticated user could trigger execution of an installed Lua script with controlled input, potentially leading to unexpected actions in the home automation system. The risk applies to Domoticz installations with multiple user accounts.

Recommendation

Update Domoticz to version 2026.3. Until updated, limit low-privilege accounts and monitor requests to /json.htm with the udevices parameter.

Other vulnerabilities in Domoticz

See all
Original NVD description (English source)

Domoticz is a free, open source home automation system for Linux, Windows, macOS, and Raspberry Pi. Prior to 2026.3, the `udevices` JSON command handler, `Cmd_UpdateDevices` in `main/WebServerCmds.cpp`, performed no `session.rights` check before invoking a Lua parser script, while its sibling command handlers gate access by role. A low-privilege authenticated user could trigger execution of an existing operator-installed Lua parser script with attacker-controlled input through the `GET /json.htm` endpoint with `type=command` and `param=udevices`. The `script` parameter also lacked a `..` path-traversal guard: `CLuaHandler::executeLuaScript` in `main/LuaHandler.cpp` constructed the filename from the parser directory and the supplied script name before passing it to `luaL_loadfile`. Execution is limited to already-installed valid Lua files; this is not arbitrary code execution, and the advisory states that file-write and upload paths require administrator privileges. This issue is addressed in version 2026.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS